Selecting "Sort Folder..." from context menu in Bookmark Manager results in XML Parsing Error: undefined entity (sortFolder.xul)

RESOLVED FIXED

Status

SeaMonkey
Bookmarks & History
--
major
RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: Lewis Rosenthal, Assigned: u88484)

Tracking

({regression})

Trunk
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

1.15 KB, patch
neil@parkwaycc.co.uk
: review+
jag (Peter Annema)
: superreview+
Robert Kaiser
: approval-seamonkey1.0+
Robert Kaiser
: approval-seamonkey1.1a+
Details | Diff | Splinter Review
(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.9a1) Gecko/20051201 MultiZilla/1.8.1.0u SeaMonkey/1.5a
Build Identifier: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.9a1) Gecko/20051201 MultiZilla/1.8.1.0u SeaMonkey/1.5a

Note subject of this bug. Attempting to sort bookmark folder opens error window reporting XML parsing issue in chrome://communicator/content/bookmarks/sortFolder.xul. Folder cannot be sorted (other than predefined "Sort Folder by Name."

Reproducible: Always

Steps to Reproduce:
1. Open Bookmark Manager.
2. Right-click a bookmark folder.
3. Select "Sort Folder..." from context menu.
Actual Results:  
Error window opens, with the following:

XML Parsing Error: undefined entity
Location: chrome://communicator/content/bookmarks/sortFolder.xul
Line Number 97, Column 19:                  <menuitem value="ascending" label="&sortAscending.label;"/>
------------------^

Expected Results:  
Sort options window should open.

Comment 1

13 years ago
Yes, that seems to be a regression from the checkin from bug 301562. Because the fix is already part of the bug there, I will dupe this one over there.

*** This bug has been marked as a duplicate of 301562 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Keywords: regression
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
> Yes, that seems to be a regression from the checkin from bug 301562. Because
> the fix is already part of the bug there, I will dupe this one over there.
> 
> *** This bug has been marked as a duplicate of 301562 ***
> 

Thanks, Peter.
(Assignee)

Comment 3

13 years ago
Reopening will attach patch in a minute.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Assignee)

Comment 4

13 years ago
Created attachment 205624 [details] [diff] [review]
Patch to fixed regression

This should fix the regression...does anyone else need to review this.
Assignee: p_ch → supernova_00
Status: UNCONFIRMED → ASSIGNED
Attachment #205624 - Flags: review?
(Assignee)

Updated

13 years ago
Attachment #205624 - Flags: review? → review?(neil.parkwaycc.co.uk)

Comment 5

13 years ago
Created attachment 205626 [details] [diff] [review]
Patch for DTD only

Actually, the sortFolder.xul part is already in, so we only need this two-line change to sortFolder.dtd.
Attachment #205624 - Attachment is obsolete: true
Attachment #205626 - Flags: superreview?(jag)
Attachment #205626 - Flags: review?(neil.parkwaycc.co.uk)
Attachment #205624 - Flags: review?(neil.parkwaycc.co.uk)

Updated

13 years ago
Attachment #205626 - Flags: superreview?(jag) → superreview+

Updated

13 years ago
Attachment #205626 - Flags: review?(neil.parkwaycc.co.uk) → review+

Comment 6

13 years ago
This affects Windows and MacOSX too.
OS: OS/2 → All
Hardware: PC → All
Version: unspecified → Trunk

Comment 7

13 years ago
*** Bug 319855 has been marked as a duplicate of this bug. ***

Updated

13 years ago
Whiteboard: [checkin needed]
(Assignee)

Comment 8

13 years ago
Patch checked in by timelyx.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → FIXED

Comment 9

13 years ago
Comment on attachment 205626 [details] [diff] [review]
Patch for DTD only

Actually it's too late at night for me to check which approval(s) are needed ;-)
Attachment #205626 - Flags: approval-seamonkey1.1?
Attachment #205626 - Flags: approval-seamonkey1.0?

Comment 10

13 years ago
Are you sure this is needed in 1.8 at all? There is no indication in the checkins in bug 301562 that they went into branch (neither were approvals given). If you want the wording change in SeaMonkey 1.0 and 1.1 you would also need the corresponding to sortFolder.xul (and to the history.* files as well).

Updated

13 years ago
Attachment #205626 - Flags: approval-seamonkey1.1?
Attachment #205626 - Flags: approval-seamonkey1.1+
Attachment #205626 - Flags: approval-seamonkey1.0?
Attachment #205626 - Flags: approval-seamonkey1.0+

Comment 11

13 years ago
You're right, thanks for checking.
Whiteboard: [checkin needed]
You need to log in before you can comment on or make changes to this bug.