thebreastcancersite.com - Graphics boxes don't display and information is missing (bad scripts)

RESOLVED WORKSFORME

Status

Tech Evangelism Graveyard
English US
RESOLVED WORKSFORME
12 years ago
3 years ago

People

(Reporter: Larry Kohout, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

When you bring up web sites with push buttons and the like these buttons sometimes do not show or only partially show and a user is unaware of information on a site.  I first noticed it at the Breast Cancer site referenced above where the "Click every day to provide free mammograms" botton was missing but the words were there.  I then was completely lost when I went to http://www.ppass.bc.ca/ and there is a Navy Blue bar near the top of the page.  That bar contains buttons to press for various functions when viewed in IE.  None of those functions are available in Firefox.  I also reported a problem to Adobe software today in that only one of my products was showing up in my list of products in my profile.  The Customer Service rep was taking the report and asked what browser I was using.  He then asked me to reopen the site with IE.  When I did all my products were visible.  He said he didn't understand it but that Firefox didn't like there site and they always have to ask users to change browsers.  

Reproducible: Always

Steps to Reproduce:
1.Go to the two referenced URLs and look at them in Firefox
2.Go back and look at the same URL in IE
3.See the difference.

Actual Results:  
You can't see the graphics when using Firefox and you can when you use IE.

Expected Results:  
I should be able to see exactly the same thing in Firefox that I see in IE

I'm running an HP Pavilion zv6000 AMD64 Athlon that I've only had for a month.  I doubt that this has any bearing on the issue but mention it just in case.
Component: Disability Access → General
ppass.bc.ca is using proprietary JavaScript (checking for document.all, then document.layers, then fallback to nothing).  This will only work in IE or Netscape 4.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 2

12 years ago
Well that's just fine, don't fix it.  But I'll tell you, I quit using the product long ago because of the bug.  I also suspect that a whole lot of others have done the same.  The thing is worthless if you can't use it and see web sites displayed as they are formatted and enter information into the boxes.  So go ahead with your superior geek attitude, what percentage of the market does your product cover?
Depends on what market you're talking about.  Firefox is and always will be standards driven.  If the case at hand isn't standard code, then it's not a bug in firefox. You can use the report broken website feature in firefox, or we can reopen this bug and change the component to tech evangelism, to push the site developers to use standard code that all browsers can handle.
 
If you want to use a browser that shows quirky code, then that's fine, firefox isn't about replacing one monopoly with another.  Of course there are extensions that let you view sites as i.e. would display them if you really want to use firefox.  
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
Assignee: nobody → english-us
Status: UNCONFIRMED → NEW
Component: General → English US
Ever confirmed: true
OS: Windows XP → All
Product: Firefox → Tech Evangelism
QA Contact: disability.access → english-us
Hardware: PC → All
Summary: Graphics boxes don't display and information is missing on several web sites → thebreastcancersite.com - Graphics boxes don't display and information is missing (bad scripts)
Problem not found
Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:22.0) Gecko/20100101 Firefox/22.0
Status: NEW → RESOLVED
Last Resolved: 12 years ago4 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.