XPath exceptions are reported as unknown

VERIFIED FIXED in mozilla1.9alpha1

Status

()

P3
normal
VERIFIED FIXED
13 years ago
13 years ago

People

(Reporter: Seno.Aiko, Assigned: peterv)

Tracking

({regression})

Trunk
mozilla1.9alpha1
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
Since the 2005-11-19 nightly build XPath exceptions are "unknown". For example, the following statement
   document.evaluate("2", document, null, 1, null).booleanValue
should print this in the JS console (and did so in 2005-11-18 build):

Error: uncaught exception: [Exception... "The expression cannot be converted to return the specified type."  code: "52" nsresult: "0x805b0034 (NS_ERROR_DOM_TYPE_ERR)"  location: "javascript: document.evaluate("2", document, null, 1, null).booleanValue Line: 1"]

With newer build I instead get:

Error: uncaught exception: [Exception... "Component returned failure code: 0x805b0034 [nsIDOMXPathResult.booleanValue]"  nsresult: "0x805b0034 (<unknown>)"  location: "JS frame :: javascript: document.evaluate("2", document, null, 1, null).booleanValue :: <TOP_LEVEL> :: line 1"  data: no]

The patch for bug 314931 looks like a probable cause.
(Assignee)

Updated

13 years ago
Status: NEW → ASSIGNED
Priority: -- → P3
Target Milestone: --- → mozilla1.9alpha
(Assignee)

Comment 1

13 years ago
Created attachment 206691 [details] [diff] [review]
v1

I suck.
Attachment #206691 - Flags: superreview?(jst)
Attachment #206691 - Flags: review?(jst)
Comment on attachment 206691 [details] [diff] [review]
v1

r+sr=jst
Attachment #206691 - Flags: superreview?(jst)
Attachment #206691 - Flags: superreview+
Attachment #206691 - Flags: review?(jst)
Attachment #206691 - Flags: review+
(Assignee)

Updated

13 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
(Reporter)

Updated

13 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.