Currently, if nsImageLoadingContent or nsObjectLoadingContent want to implement a new interface, the QueryInterface impls of all subclasses have to be changed. This is also some code duplication. Instead, these two classes should maybe have their own QueryInterface method that handles their interfaces, and subclasses just call that. This might be a bit problematic because subclasses may want to call various superclass's QI methods (nsGenericHTMLElement or something).
jst, what do you think of adding a macro to do something like this?