seamonkey can't build with layout-debug extension

VERIFIED INVALID

Status

SeaMonkey
Build Config
VERIFIED INVALID
13 years ago
13 years ago

People

(Reporter: Ginn Chen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
Here's the error message.

make[5]: Entering directory `/home/ginn/mozillatrunk1130/mozilla/nsprpub/pr/incl
ude/md'
../../../config/./nsinstall -R -m 444 ./_aix32.cfg ./_aix64.cfg ./_beos.cfg ./_b
sdi.cfg ./_darwin.cfg ./_dgux.cfg ./_freebsd.cfg ./_hpux32.cfg ./_hpux64.cfg ./_
irix32.cfg ./_irix64.cfg ./_linux.cfg ./_ncr.cfg ./_nec.cfg ./_netbsd.cfg ./_nex
tstep.cfg ./_nto.cfg ./_openbsd.cfg ./_openvms.cfg ./_os2.cfg ./_osf1.cfg ./_qnx
.cfg ./_reliantunix.cfg ./_rhapsody.cfg ./_riscos.cfg ./_scoos.cfg ./_solaris.cf
g ./_sony.cfg ./_sunos4.cfg ./_unixware7.cfg ./_unixware.cfg ./_win16.cfg ./_win
95.cfg ./_winnt.cfg /home/ginn/mozillatrunk1130/mozilla/dist/include/nspr/md
../../../config/./nsinstall -R -m 444 ./ /home/ginn/mozillatrunk1130/mozilla/dis
t/include/nspr
../../../config/./nsinstall: cannot make symbolic link /home/ginn/mozillatrunk11
30/mozilla/dist/include/nspr/.: File exists
make[5]: *** [export] Error 1
make[5]: Leaving directory `/home/ginn/mozillatrunk1130/mozilla/nsprpub/pr/inclu
de/md'
make[4]: *** [export] Error 2
make[4]: Leaving directory `/home/ginn/mozillatrunk1130/mozilla/nsprpub/pr/inclu
de'
make[3]: *** [export] Error 2
make[3]: Leaving directory `/home/ginn/mozillatrunk1130/mozilla/nsprpub/pr'
make[2]: *** [export] Error 2
make[2]: Leaving directory `/home/ginn/mozillatrunk1130/mozilla/nsprpub'
make[1]: *** [nspr] Error 2
make[1]: Leaving directory `/home/ginn/mozillatrunk1130/mozilla'
make: *** [default] Error 2

Here's my mozconfig.
mk_add_options MOZ_CO_PROJECT=suite
ac_add_options --enable-application=suite
ac_add_options --enable-default-toolkit=gtk2
ac_add_options --enable-extensions=default, layout-debug
ac_add_options --disable-gtktest
ac_add_options --disable-libIDLtest
ac_add_options --disable-glibtest
ac_add_options --disable-tests
ac_add_options --with-xprint
ac_add_options --enable-xinerama
ac_add_options --enable-ldap
ac_add_options --enable-xft
ac_add_options --disable-freetype2
ac_add_options --disable-auto-deps
ac_add_options --enable-crypto
ac_add_options --disable-ctl
ac_add_options --enable-debug

I didn't have this problem with Mozilla 1.7 or Firefox trunk.

Comment 1

13 years ago
That error is unrelated to the layout-debug extension (which I built fine with this morning).  Something's wrong with your build configuration because NSPR is trying to install "./" into dist/include/nspr/ which means that MDCPUCFG_H is unset in nsprpub/pr/include/md/Makefile.in, which means that you told configure to use an unsupported configuration (we should really check for that explicitly).

Can you provide the full build output (including the configure output) as well as the contents of your mozconfig file if you're using one.

Comment 2

13 years ago
Helps if I scroll down when commenting. ;-)  The problem is in your mozconfig file:
  ac_add_options --enable-extensions=default, layout-debug

In particular, the space is causing layout-debug to be treated as a standalone argument to configure which is treating it as a platform type.  You'll need to remove the space or use quotes.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

13 years ago
Thanks!
I didn't aware the space.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.