Thunderbird crashing while sorting threads [@ nsMsgQuickSearchDBView::SortThreads]

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
13 years ago
10 years ago

People

(Reporter: guy, Assigned: Bienvenu)

Tracking

1.8 Branch
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/416.11 (KHTML, like Gecko) Safari/416.12
Build Identifier: version 1.5 (20051025)

Thunderbird's crashed twice when I clicked on my Junk mailbox, which is threaded (to collapse all the tons of Sober virus messages into a smaller list).

I compacted the folders, and, after that, I clicked on my Junk mailbox and it didn't crash.

Reproducible: Sometimes

Steps to Reproduce:
1. Get new mail.
2. Click on Junk mailbox to check those new messages that were classified as junk
Actual Results:  
It crashed.

Expected Results:  
I expected to see my Junk folder.

See TalkBack crash IDs TB12564856Y and TB12564946X.
(Reporter)

Comment 1

13 years ago
Created attachment 204917 [details]
CrashReporter information about the crash.

Comment 2

13 years ago
Incident ID: 12564856
Stack Signature	nsMsgQuickSearchDBView::SortThreads() d9680d99
Product ID	Thunderbird15
Build ID	2005102519
Trigger Time	2005-12-03 15:07:11.0
Platform	MacOSX
Operating System	Darwin 8.3.0
Module	thunderbird-bin + (00202580)
URL visited	
User Comments	Clicking on my junk mailbox to look at mail Thunderbird had moved there. Here's the information from CrashReporter: Date/Time: 2005-12-03 15:07:07.431 -0800 OS Version: 10.4.3 (Build 8F46) Report Version: 3 Command: thunderbird-bin Path:
Since Last Crash	361635 sec
Total Uptime	698745 sec
Trigger Reason	SIGBUS: Bus Error: (signal 10)
Source File, Line No.	nsHttpChunkedDecoder.cpp, line 848
Stack Trace 	
nsMsgQuickSearchDBView::SortThreads()   nsMsgQuickSearchDBView::SortThreads()   nsMsgQuickSearchDBView::OnSearchDone()   nsMsgSearchSession::NotifyListenersDone()  [/builds/tinderbox/Tb-Mozilla1.8/Darwin_7.9.0_Depend/mozilla/mailnews/base/search/src/nsMsgSearchSession.cpp, line 256]
nsMsgSearchSession::TimerCallback()  [/builds/tinderbox/Tb-Mozilla1.8/Darwin_7.9.0_Depend/mozilla/mailnews/base/search/src/nsMsgSearchSession.cpp, line 532]
Assignee: mscott → nobody
Component: Mail Window Front End → MailNews: Search
Product: Thunderbird → Core
QA Contact: search
Summary: Thunderbird crashing while sorting threads → Thunderbird crashing while sorting threads [@ nsMsgQuickSearchDBView::SortThreads]
Version: unspecified → 1.8 Branch
(Assignee)

Comment 3

13 years ago
I might have a fix for this in my tree...
Assignee: nobody → bienvenu
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 4

13 years ago
I just had another crash (talkback ID TB12597323E) - right after some odd behavior in the Junk mailbox.  I'd just downloaded mail, and went to Junk to quickly check the new junk (to see if anything had been wrongly marked and fix that) and then mark the Junk mailbox as "all read".  "Mark as all read" left a thread of about 3 or 4 messages still marked as unread, but the count of unread messages in the sidebar went to 1.  I marked the top of the thread as read; the entire thread was then marked as read, but the sidebar message count stayed at 1.  I clicked in the Inbox, and then went back to Junk, and it crashed.

In the past, I've seen Thunderbird show a non-zero count for Junk in the sidebar, even though there aren't any unread messages (I have Junk set to display only unread messages), and it sometimes will give a too-low count of unread messages in Inbox - exiting and restarting Thunderbird fixes the counts.
(Reporter)

Comment 5

13 years ago
I re-compacted the folders, and was again able to go back to my Junk mailbox.

It still claimed there was one unread message and, in fact, when I want to the mailbox, there was one messages marked as unread.  I clicked in the blue "unread" marker and the count of unread messages went to zero.

Might the fix address the other issues I mentioned, or should I file separate bugs on them?

Comment 6

12 years ago
dupe of bug 331676 or bug 352287

Comment 7

11 years ago
no crashes for trunk or TB v2 recorded on talkback 
(two recorded for v1.5, one linux, one MAC)

closing WFM per crash servers
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.