tool bar button in menu bar disappears

RESOLVED DUPLICATE of bug 288079

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 288079
13 years ago
10 years ago

People

(Reporter: Mikel Ward, Assigned: Scott MacGregor)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
Buttons don't properly stay in the top tool bar row (the one also containing the main menu bar).

1. Right click in a blank area on the tool bar, select Customize...
2. Drag a tool icon (such as Write, the icon with a piece of paper and a pen)
   from the Mail tool bar to the menu bar (on the left of the File menu)
3. Click OK
4. Repeat step 1
5. Scroll the dialog box down so you can see the View label in the Search bar
6. Click on the View label
7. Click Cancel

The Write icon then disappears from the menu bar, despite it having been previously accepted and stored.

Comment 1

10 years ago
cancel doesn't keep them on the toolbar. OK is necessary to complete the process.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

10 years ago
Please re-read the bug report.

The icon is added in step 2 and OK'd in step 3.

Cancel should only undo steps 4-6.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---

Comment 3

10 years ago
your problem was on version 1.5.
Can you recreate step 2 with version 2 or current trunk build?
I can't recreate step 2 (click OK and have customizes stay open) sending the icon to the menu bar or the mail toobar.
version 2.0.0.12 (20080213)
current trunk
That's because that's not at all what step 2 is: step 3 is click OK, step 4 is reopen customize.

However, you're not going to find it in 2.0 or trunk, because I fixed it quite a while back.
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 288079
You need to log in before you can comment on or make changes to this bug.