Update denies extensions with Mozilla 1.0 compatability

RESOLVED FIXED in 1.0

Status

addons.mozilla.org Graveyard
Developer Pages
--
blocker
RESOLVED FIXED
12 years ago
2 years ago

People

(Reporter: James Ross, Assigned: morgamic)

Tracking

({regression})

unspecified
regression

Details

(URL)

(Reporter)

Description

12 years ago
I just tried to update ChatZilla on UMO, and it refused, saying:

  Error! The MinAppVer for Mozilla of 1.0 in install.rdf is invalid.

Mozilla 1.0 is a PERFECTLY valid entry!

Just for the record, I don't give a damn what the list in the FAQ says - it doesn't even mention the GUIDs for each product - the version was accepted previously, and is valid.

Comment 1

12 years ago
If it was accepted previously, that means it was removed, who removed records from the applications table, who approved it and why?

Comment 2

12 years ago
Noone removed records from the applications table. The check for acceptable versions was changed to ensure that the Applications were public versions, despite the Applications page saying that "Should this version be exposed to end-users of the website, or just allowed for extension authors' install.rdf files? In general only release milestones should be exposed." - if its set non-public, it can not even be used for Extension Authors now.

This was changed in http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&subdir=mozilla/webtools/update/developers&command=DIFF_FRAMESET&file=additem.php&rev1=1.11.2.5&rev2=1.11.2.6&root=/cvsroot

I've set Mozilla 1.0 public, since it has worked in the past.
Assignee: Bugzilla-alanjstrBugs → morgamic
(Assignee)

Comment 3

12 years ago
Result of a non-public version.  GUID problem should be resolved with the (overdue) implementation of bug 290642.

Would you rather see the GUIDs in the FAQ?  That can be arranged as well.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

12 years ago
(In reply to comment #3)
> Would you rather see the GUIDs in the FAQ?  That can be arranged as well.

I find the list in the FAQ completely useless without the GUIDs, given the install.rdf which it complained about uses them.
(Assignee)

Comment 5

12 years ago
Thanks for your input.

Would you rather see the GUIDs in the FAQ?  That can be arranged as well.
(Assignee)

Comment 6

12 years ago
I'll add the GUID to the FAQ page.
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.