Closed Bug 319057 Opened 14 years ago Closed 12 years ago

no-ads.pac not working with Seamonkey 1.0A1 or nightly as of 12-4-2005, or 1.0b

Categories

(SeaMonkey :: General, defect, major)

x86
Windows 98
defect
Not set
major

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: jlayoj3121968, Unassigned)

References

()

Details

(Whiteboard: H'n'C)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.9a1) Gecko/20051203 SeaMonkey/1.5a
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.9a1) Gecko/20051203 SeaMonkey/1.5a

no-ads.pac, from http://www.schooner.com/~loverso/no-ads/ , is not working at all with Seamonkey. It worked fine with Mozilla 1.7.11 and earlier. I think it worked with 1.7.12 as well. I'm have no idea if this a simple failure to check the proxy autoconfig file, or a failure within its execution. It may represent a general failure of PAC support.

Reproducible: Always

Steps to Reproduce:
1. Download & install the no-ads.pac file from http://www.schooner.com/~loverso/no-ads/ or the attachment (to be uploaded momentarily.)
2. Open the file in Seamonkey & copy the URL to the Advanced > Proxies > Automatic Proxy Configuration URL field.
3. Close & relaunce Seamonkey & verify the above setting to make doubly sure it's loaded.
4. Browse to http://customwire.ap.org/dynamic/fronts/HOME?SITE=VAFRE&SECTION=HOME
Actual Results:  
You'll see ads above, to the right, and below the content.

Expected Results:  
No ads.

If this is a general failure of PAC support, it could prevent Seamonkey from being used in some places.
Save anywhere and point your autoconfig setting to its file URL.
Attachment #204963 - Attachment mime type: application/octet-stream → text/plain
You cleared your cache before? Do you see any errors in the JS console?
Version: unspecified → Trunk
I used a fresh profile. I didn't check the js console. I'll try that.
The Javascript console shows nothing when I view the page with Mozilla 1.7.11.

With Seamonkey nightly build 2005120309 I get the following...
Warning: Key event not available on some keyboard layouts: key="f" modifiers="control,alt"
Source File: chrome://navigator/content/navigator.xul
Line: 0
Warning: Key event not available on GTK2: key="d" modifiers="accel,shift"
Source File: chrome://navigator/content/navigator.xul
Line: 0
Warning: Key event not available on some keyboard layouts: key="f" modifiers="control,alt"
Source File: chrome://navigator/content/navigator.xul
Line: 0
Warning: Key event not available on GTK2: key="d" modifiers="accel,shift"
Source File: chrome://navigator/content/navigator.xul
Line: 0
Error: Unknown property 'font-face'.  Declaration dropped.
Source File: http://customwire.ap.org/specials/stylesheets/w_nn_style.css
Line: 187
Error: Unknown property 'font-face'.  Declaration dropped.
Source File: http://customwire.ap.org/specials/stylesheets/w_nn_style.css
Line: 188
Error: Expected declaration but found '1px'.  Skipped to next declaration.
Source File: http://customwire.ap.org/specials/stylesheets/w_nn_style.css
Line: 198
Error: Unknown property 'font-face'.  Declaration dropped.
Source File: http://customwire.ap.org/specials/stylesheets/w_nn_style.css
Line: 242
Error: Unknown property 'font-face'.  Declaration dropped.
Source File: http://customwire.ap.org/specials/stylesheets/w_nn_style.css
Line: 244
Error: Unknown property 'font-face'.  Declaration dropped.
Source File: http://customwire.ap.org/specials/stylesheets/w_nn_style.css
Line: 261
Error: Unknown property 'font-face'.  Declaration dropped.
Source File: http://customwire.ap.org/specials/stylesheets/w_nn_style.css
Line: 432
Error: Unknown property 'font-face'.  Declaration dropped.
Source File: http://customwire.ap.org/specials/stylesheets/w_nn_style.css
Line: 440
Error: Selector expected.  Ruleset ignored due to bad selector.
Source File: http://customwire.ap.org/specials/stylesheets/w_nn_style.css
Line: 455

The Javascript Debugger in 1.7.11 lists several loaded files, including the PAC file. In Seamonkey it lists none.

FWIW, I installed Seamonkey from the seamonkey-1.5a.en-US.win32.installer.exe file. Maybe I'll try the zip or the stub if there's nothing in this info that helps ID the problem.
Same results in Seamonkey Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8) Gecko/20051219 SeaMonkey/1.0b

For my own use, I would stick with Mozilla 1.7.12 as long as Seamonkey has this bug. Should this block 1.0?

I have not tested any recent FireFox versions to see if it does the same.
Summary: no-ads.pac not working with Seamonkey 1.0A1 or nightly as of 12-4-2005 → no-ads.pac not working with Seamonkey 1.0A1 or nightly as of 12-4-2005, or 1.0b
Could you please post which URL you use in the Advanced > Proxies > Automatic Proxy Configuration URL field?
I have as my Automatic Proxy Configuration URL: file:///C:/Program%20Files/mozilla.org/no-ads.pac

If you follow the "Steps to Reproduce" in the initial bug description and save the no-ads.pac attachment in the directory "C:\Program Files\mozilla.org\" in step 1 you'll end up with the same thing.

This is on both Windows 2000 Pro and Windows 98 SE. I don't have ready access to XP or other versions of Windows, or any other OS, but will have access to XP Home on Christmas day. I may not have time to test it then, of course, so I'd appreciate it if other folks could test this on other OSes. I have little doubt it will happen on other versions of Windows, though.
Well, this is wfm with SeaMonkey 1.0b and a current trunk build on Win2k, the ads on http://customwire.ap.org/dynamic/fronts/HOME?SITE=VAFRE&SECTION=HOME are blocked.
And that's with no other image blocking or other ad blocking technology active, Frank? Very puzzling. Did you use a fresh profile generated by the version in question?
Nope, no other ad blocking or such. I also tried it again with Win98 SE (in VMware) and a really clean install of Win98 and SeaMonkey 1.0b, the ads are blocked properly. No other adblocking programs involved.
Hmmm... what about the installation file? Did you use the zip, the installer, or the stub installer?  Also, perhaps more significantly, did you use the english version or the german?

I've tried the english installer. When I have the time I plan to try the other two. If I could read German I'd try those too.
I used the English installer version.
WFM with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051219 SeaMonkey/1.0b using the zip.  I set my Proxy Configuration URL to file:///C:/Program%20Files/mozilla.org/no-ads.pac, and all ads on that page (and a few other pages I tested) appear to be blocked.  I'm not using any other form of ad or image blocking.
I'm confused now. I installed SM1.0b from the zip file in a different directory, and the PAC works fine, even using a profile for which it didn't work for an install done with the installer. (Not the stub installer. I haven't tried that.)

One other symptom I noticed when running the apparently broken installation: the Javascript debugger kept giving me errors about x-jsd not being a registered protocol. Could there be something corrupted where the installer is putting things? As I said, this has been hapenning since 1.8b, and on two different boxes each running a different version of Windows (98SE & 2000 Pro.) Could the 1.8b installation have screwed something up for all subsequent installations?
Tried this in a new profile, WFM.
This is probably obsolete due to the existence of Adblock Plus anyway ;-)
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → WORKSFORME
Whiteboard: H'n'C
You need to log in before you can comment on or make changes to this bug.