Status

()

Firefox
General
RESOLVED DUPLICATE of bug 243751
12 years ago
12 years ago

People

(Reporter: Marcelo Aires Caetano, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; pt-BR; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; pt-BR; rv:1.8) Gecko/20051111 Firefox/1.5

when use a image background to body on new gecko, the image places wrong e.g.:
body {
        font-family:sans-serif;
        font-size:small;

        background-image:url(images/logo.jpg);
        background-repeat:no-repeat;
        background-position:center;
}

the image wont centralize in vertical

Reproducible: Always

Actual Results:  
the image wont centralize in vertical

Expected Results:  
background-position:center; be centered on body
Not had a problem with this, but note that often the body element is not the full viewport height so while the image is vertically centered in the body, it is stuck at the top of the viewport. Do you have an example page to look at or that can be attached to the bug?
(Reporter)

Comment 2

12 years ago
(In reply to comment #1)
> Not had a problem with this, but note that often the body element is not the
> full viewport height so while the image is vertically centered in the body, it
> is stuck at the top of the viewport. Do you have an example page to look at or
> that can be attached to the bug?
> 

On All other browsers, the image centralize at vertical too, like opera, konqueror, the example is: http://rockristao.homeip.net:7777/cbn/ look with firefox 1.5 and previous version please, thankyou :)
Since the div containing all the page content is removed from the main flow by position: absolute, the body element ends up being only around 20px high at the top of the page, so the background on the body only displays there.


*** This bug has been marked as a duplicate of 243751 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

12 years ago
You're right, thankyou
You need to log in before you can comment on or make changes to this bug.