three consecutive exclamation points in subject lines closes window automatically

RESOLVED WORKSFORME

Status

Thunderbird
Mail Window Front End
RESOLVED WORKSFORME
13 years ago
12 years ago

People

(Reporter: xrlq, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

My cousin sent me a message with the subject line reading "Another option!!!" and it read fine in the lower "preview" pane, which is the way I read most incoming emails, but when I tried replying it created a message in a new window, then instantly closed it.  I tried replying to other messages and did not have this problem.  I closed down Thunderbird and restarted it, same problem, still confined to this one message.  I then tried creating a new message, copying and pasting the text of the original in, and manually creating a subject line that read "Re: Another Option!!!".  As soon as I typed the third exclamation point, I got a dialog box that read "Message has not been sent.  Do you want to save the message in the Drafts folder?" and offered the options Save, Don't Save and Cancel.  If I cancel the dialog box reappears immediately.

I then tried creating new emails from scratch, using other subject lines, but the third exclamation point creates the same problem every time.

Reproducible: Always

Steps to Reproduce:
1.  Begin writing a new message.
2.  Type anything in the subject line that contains three exclamation points in a row.

Actual Results:  
It closed the window, prompting me to save a draft

Expected Results:  
Nothing.

Nothing.  It should have left me alone and allowed me to write the message.

Comment 1

13 years ago
Worksforme on Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051202 Thunderbird/1.5 ID:2005120207. 

Have you tried thunderbird 1.5rc?

Comment 2

13 years ago
WFM with TB 1.0.7, Win2K, as well as 1.5rc1 and 1.6a1-1201.

Do you have extensions installed?  If so, try running TB in SafeMode to see if one of the extensions is somehow interfering with the composition.

Comment 3

12 years ago
No response from reporter  => WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.