Event notdefined: ymouse = (ns)?evnt.pageY+ClockFromMouseY-(window.pageYOffset):event.y+ClockFromMouseY;

RESOLVED INVALID

Status

Toolkit Graveyard
Error Console
--
major
RESOLVED INVALID
12 years ago
a year ago

People

(Reporter: Gary Bruno Schmid, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8) Gecko/20051111 Firefox/1.5

I am the owner of the site www.mind-body.info.
Opening the site in Internet Explorer shows a "crazy clock" rotating around the curser with the letters etc. following the cursor around as it is moved.
Opening the site in FireFox (on my Mac OSX 10.4 Tiger at home, or at work on my PC with MS Windows XP 2002)does not show the "crazy clock".  The JavaScript Console gives the error: "even is not defined" at line 197
ymouse = (ns)?evnt.pageY+ClockFromMouseY-(window.pageYOffset):event.y+ClockFromMouseY;
Since FireFox is my own default browser, I'd like to see this effect working.

Reproducible: Always

Steps to Reproduce:
1.go to www.mind-body.info
2.open JavaScript Console and read the error
3.compare to properly working site by opening www.mind-body.info in Internet Explorer (on Mac or PC).

Actual Results:  
I see what I want in Internet Explorer but not in FireFox!

Expected Results:  
The site should look the same in both browsers.

Maybe I need some kind of special plug-in code from you folks so that I can reprogramm my web page to work properly for everyone in FireFox.

I assume that, since the problem is with a mouse event (major feature), this problem is of major severity affecting more important things than my "crazy clock".  For this reason, I have checked "Severity: Major" below.
The problem with your site is that it is using Internet Explorer specific coding, hence the error. This isn't a problem with Firefox. Explorer uses window.event to access the current event, while Firefox uses the w3c model of passing events as parameters to handlers.

http://www.quirksmode.org/dom/w3c_events.html is a good reference for how event handling works, in both IE and Firefox.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
(Assignee)

Updated

a year ago
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.