email addresses are CAPS-sensitive

RESOLVED DUPLICATE of bug 129393

Status

RESOLVED DUPLICATE of bug 129393
13 years ago
9 years ago

People

(Reporter: torsionality, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

the email addresses collected by the address book with the 'automatically add outgoing email' check box are caps-sensitive.
For example, if I have foo.bar@mozilla.org in my address book, and reply to an email from Foo.Bar@mozilla.org, it adds another entry.

Reproducible: Always

Steps to Reproduce:
1.Have the auto-add feature turned on (in options - composition)
2.Have coworkers that insist on random capitalization in addresses
3.reply to email where the address has different caps than in the address book



Expected Results:  
The check against the address book should be caps-neutral when sending mail.

Comment 1

13 years ago
I'm not sure this is correct.
RFC says that the localpart has to be considered case-sensitive and the domain case-insensitive.
I know the case where multiple email addresses:
address@domain.com 
Address@domain.com
aDDress@domain.com
all exists and each point to a different account is unlikely to happen but it cannot be considered a rule.

Mozilla should probably ask wether it should consider the local part case insensitive or not (global preference or contact specific preference).

*** This bug has been marked as a duplicate of 129393 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
To the best of my knowledge this bug still exists in the main code.  To get it
fixed please go to bug 129393 and click the vote button to raise its level of importance.
You need to log in before you can comment on or make changes to this bug.