dimensionless font size setting does not work for fonts in SVG

RESOLVED DUPLICATE of bug 311569

Status

()

Core
SVG
RESOLVED DUPLICATE of bug 311569
13 years ago
13 years ago

People

(Reporter: Ivan Herman, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

The file includes two <text> element, one has its size set via a CSS style element, the other with an presentation attribute using the same value. The two texts should look the same, they do not. More precisely, the text with presentation attribute is correct, the CSS is not.

http://www.w3.org/TR/2003/REC-SVG11-20030114/styling.html#UsingPresentationAttributes says that "For user agents that support CSS, the presentation attributes must be translated to corresponding CSS style rules [...] are conceptually inserted into a new author style sheet which is the first in the author style sheet collection", ie, there should be no difference whatsoever between the two rendering. Furthermore, http://www.w3.org/TR/2003/REC-SVG11-20030114/text.html#FontPropertiesUsedBySVG explicitly says, when defining font-size: "http://www.w3.org/TR/2003/REC-SVG11-20030114/text.html#FontPropertiesUsedBySVG"

Ie, the dimensionless font-size attribute should work properly.



Reproducible: Always

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 311569 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Component: General → SVG
Product: Firefox → Core
Resolution: --- → DUPLICATE
Version: unspecified → Trunk
You need to log in before you can comment on or make changes to this bug.