keyboard shorcuts don't work with a non-latin layout, ignoring `xkb' configuration

RESOLVED DUPLICATE of bug 246491

Status

()

Firefox
Keyboard Navigation
--
minor
RESOLVED DUPLICATE of bug 246491
13 years ago
11 years ago

People

(Reporter: Paul Pogonyshev, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

My `xkb' is configured with two layouts: English and Russian.  The Russian layout is configured with latin included, so that shortcuts like `Ctrl+W', `Ctrl+S' etc. work as if I always use the English layout.  (I.e. even if I type `Ctrl+Ц' or `Ctrl+Ы', programs still interpret these as `Ctrl+W' and `Ctrl+S'.)  However, Firefox doesn't do this, which makes using the Russian layout much more difficult: I have to switch layouts to e.g. use the clipboard or create a new tab.

I entered the layout settings in KDE Control Center, but I strongly believe they are not KDE-specific.  In particular, KDE shows this command line for `xkb': `setxkbmap -model pc104 -layout us,ru -variant ,winkeys'.  Most non-KDE applications, like Gaim or the Gimp, treat the shortcuts as expected, but Firefox (though also using GTK+) doesn't.

Reproducible: Always

Steps to Reproduce:
1. Configure `xkb' for the Russian layout with latin included (KDE reports this command line: `setxkbmap -model pc104 -layout us,ru -variant ,winkeys'.)
2. Switch to the russian layout.
3. In Firefox, type `Ctrl+Ц' (i.e. as `Ctrl+W' with English layout.)

Actual Results:  
The current tab/window won't close.

Expected Results:  
The current tab/window should be closed as if I typed `Ctrl+W'.

This bug is minor as there is an obvious workaround, but it is _very_ annoying and makes using the Russian layout a nightmare :(
(Reporter)

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 246491 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.