No line number: Error in parsing value for property 'height'. Declaration dropped. Line:0

RESOLVED DUPLICATE of bug 261337

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 261337
12 years ago
12 years ago

People

(Reporter: Graham Leggett, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

When viewing the attached test.html with Firefox v1.5, the following error is logged in the Javascript Console after clicking the button:

Error: Error in parsing value for property 'height'.  Declaration dropped.
Source File: http://127.0.0.1:8080/rfs/test.html
Line: 0

For reasons unknown, this error is reported on "line 0", thus rendering it impossible to debug the javascript and find where the error is really occurring.



Reproducible: Always

Steps to Reproduce:
xxx
(Reporter)

Comment 1

12 years ago
Created attachment 205047 [details]
Test html file showing javascript error on "line 0"
(Reporter)

Comment 2

12 years ago
Bug #312888 talks about the error message "Error in parsing value for property 'height'.  Declaration dropped" appearing in Firefox v1.5. This bug refers to this error message being reported on line 0, which is a separate issue.

Comment 3

12 years ago
I don't see this with a recent seamonkey nightly on Mac OS 10.3.9. I do get an error, though:

Warning: redeclaration of function Calendar_calc_month_year
Source File: https://bugzilla.mozilla.org/attachment.cgi?id=205047&action=view
Line: 886, Column: 9
Source Code:
function Calendar_calc_month_year(p_Month, p_Year, incr) {

Comment 4

12 years ago
WFM as well with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

I guess there's an assignment to .style.height property or something like that, and it causes the error to be reported at 'line 0' - probably because the javascript engine doesn't pass the line information to the CSS parser. Same things happens, for example, when an error occurs in JS code that is written as a value of an attribute in HTML, e.g. onclick="throw 1"

The fact that it reports an error is most probably not a bug (and it doesn't report an error for me), but the fact that it reports it on line 0 /is/ a bug, although I don't think it will be fixed soon.
(Reporter)

Comment 5

12 years ago
Just to be clear: This bug report is about the "0" in "line: 0".

The javascript definitely contains bugs, however debugging the javascript is impossible, because the error message does not indicate on what line the javascript broke.

When you said Works For Me, did you see a line number > 0 against the error message, or did you see "line: 0"?

Comment 6

12 years ago
I didn't see the error itself. I think that if there was an error, it would be reported at 'line 0' for reasons provided in comment 4.
Isn't this a duplicate of bug 261337?

Comment 8

12 years ago
(In reply to comment #7)
> Isn't this a duplicate of bug 261337?

Indeed.



*** This bug has been marked as a duplicate of 261337 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.