Systems overwrite prefs.js even if directed at another file

RESOLVED INCOMPLETE

Status

Thunderbird
Account Manager
--
major
RESOLVED INCOMPLETE
13 years ago
10 years ago

People

(Reporter: ptashek, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2008-08-21)

Attachments

(1 attachment)

232.69 KB, application/x-bzip
Details
(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla Thunderbird 1.0.7 (X11/20051013)

This is regarding:
Mozilla Thunderbird 1.0.7 (X11/20051013) under Ubuntu 5.10 (x86_64)
Mozilla Thunderbird 1.0.7 (Windows/20050923) under Windows XP Professional SP2 (x86)

I have moved my mail profile under Windows to another disk and pointed Thunderbird at it. I have then created a new profile under Linux and replaced the Mail folder with a symlink to the Windows profile'. Prefs.js was replaced with a symlink to linux.js under Windows profile. So basically I have two mail profiles, two config files but one message store. That works very well except one problem: Thunderbird under Linux is ignoring the symlink prefs.js --> /some_folder/linux.js and writes *directly* to the prefs.js as found in the Windows profile. The only difference between both profiles are names of the files that keep my account passwords. If I start Thunderbird under Linux and tell password manager to store my passwords and then run it under Windows, I'm again asked for the passwords. Going back to Linux - same thing. 

The preferences (as seen from Windows) are located under T:\mail.profile\prefs.js, and under ~/.thunderbird/Profiles/mail.default/prefs.js (as seen under Linux) which is a symlink to /common/mail.profile/linux.js. T: and /common are the same partition.

I think that's as clear as I can describe it.

Reproducible: Sometimes

Steps to Reproduce:
1. Setup a shared (Windows/Linux) mail profile sharing only the mail store.
   a) setup a mail profile under Windows, including accounts
   b) copy that profile to a location accessible by both Linux and Windows
   c) change profiles.ini under Windows to point to the new location
   d) create new profile under Linux
   e) remove the prefs.js file and Mail folder
   f) copy prefs.js to linux.js from the Windows profile (leave in the same folder though) and change all paths so they reflect Linux' profile structure (dirs etc.)
   g) in you Linux mail profile create a symlink named prefs.js pointing it at linux.js created previously
   h) in your Linux mail profile create a symlink named Mail pointing at the Mail folder in the Windows profile.

2. Start either client and save your passwords, change some preferences.
3. Start the other OS and the client, download mail, change some preferences.

Actual Results:  
Both OS' are hapilly sharing the mail store but still using the same prefs.js file ignoring any redirections.

Expected Results:  
Either OS is using its own preferences, but still writing to the same mail store.

None of my clients has any extensions installed.
(Reporter)

Comment 1

13 years ago
Just a side not to "Reproducible: Sometimes"

If I run the client under either OS, store the passwords, the close the client and re-run it - the problem is not there. It shows up *only* when I run the client on one OS and then under the other. Maybe it's just some incompatibility between the format of the password file under Windows and Linux. However this is just part of the problem described earlier.
(Reporter)

Updated

13 years ago
Hardware: All → PC
Version: unspecified → 1.0
(Reporter)

Comment 2

13 years ago
Created attachment 205255 [details]
Trace output

Trace output for Thunderbird 1.0.7 under Ubuntu 5.10 x86_64 (2.6.12-10-amd64-smp)
(Reporter)

Comment 3

13 years ago
If you have a close look at the attached trace you'll see clearly where the bug is. Hint: see where Thunderbird looks initialy for prefs.js and which file it renames afterwards.
(Reporter)

Updated

13 years ago
Severity: normal → major
Component: Preferences → Account Manager
QA Contact: preferences → account-manager
Reporter, does the issue still occur in the latest supported 2.0.0.x / Shredder trunk nightlies?

(1.5.0.x is now end-of-life and the latest supported 2.0.0.x is now 2.0.0.16)
Whiteboard: closeme 2008-08-21
RESO INCO per lack of response to previous comment. If you feel this change was made in error, please respond to the bug with your reasons why.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.