Need custom title for bookmarks

RESOLVED FIXED

Status

()

Firefox
Bookmarks & History
P1
normal
RESOLVED FIXED
12 years ago
8 years ago

People

(Reporter: Annie Sullivan, Assigned: Brett Wilson)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
Right now, if I drag a link to the personal toolbar, the title of the bookmark I create is the anchor text of the link.  But then if I click the bookmark and visit the page, the bookmark's title changes to the title of the page.  There should be a custom title in this case so that the title of my bookmark doesn't change when I load the page.
(Assignee)

Comment 1

12 years ago
I was planning on doing this as an annotation, but it might get added to history as an optimization.
(Assignee)

Updated

12 years ago
OS: Windows XP → All
Priority: -- → P1
Hardware: PC → All
(Assignee)

Comment 2

12 years ago
*** Bug 318818 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 3

12 years ago
Created attachment 205918 [details] [diff] [review]
Patch for user-define titles in history

This also includes a refactor of options
Attachment #205918 - Flags: review?(bryner)
Attachment #205918 - Flags: review?(bryner) → review+
(Assignee)

Comment 4

12 years ago
Checked in backend. UI will be in the bookmark properties dialog (not done yet).
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.