Closed Bug 319237 Opened 16 years ago Closed 16 years ago

Make clicking a link default to opening a new tab instead of loading page in the current tab

Categories

(Camino Graveyard :: Tabbed Browsing, enhancement)

PowerPC
macOS
enhancement
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 274143

People

(Reporter: sxtynnmach1, Assigned: mikepinkerton)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

I love Firefox for two reasons: One is its use of window space for the bookmark sidebar, the other is its effeciency in tabbed browsing.  The latter is the problem I have with the upcoming Camino.  I've noticed on the 1.0b1 build of Camino the tabbed browsing still doesnt work as follows: when you click a link that normally opens a new window by itself, the new window will instead load a new tab in the foremost Camino window.  All I see on this subject in Camino is an option for links to be opened in new tabs by holding a certain command button while clicking.  Could this feature be made as an option for the default action, without having to hold down a command?

Reproducible: Always
Alias: Open_link_in_new_tab
(Please don't fill in the alias field; it messes up searches and annoys people working in other components.  Thanks!)
Alias: Open_link_in_new_tab
Summary: Request for tabbed browsing feature → Make clicking a link default to opening a new tab instead of loading page in the current tab
Unless I'm mistaken, what you're asking for is

user_pref("browser.link.open_newwindow", 3);

If that's the case, dupe of Bug 274143?
Yeah, this is a dupe.

cl

*** This bug has been marked as a duplicate of 274143 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.