Javascript submit does not work if hidden field exists with the name 'submit'

RESOLVED DUPLICATE of bug 72156

Status

()

--
minor
RESOLVED DUPLICATE of bug 72156
13 years ago
13 years ago

People

(Reporter: ferdinand, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

If a form has a hidden field with the name submit, a javascript submit is ignored. Nothing happend. It works with IE, konqueror fine.

I do'nt know if this is how it suppose to work, but if so, a warning in the javascriptconsole will be nice.

HTML:
<form action="doSomething.pl" name="rows">
    <select name="rowAmount" onChange="this.form.submit()">
        <option value="10">10</option>
        <option value="20">20</option>
    </select>
    <input type="hidden" name="submit" value="something">
</form>

I've this problem in FF 1.07 and 1.5 (On Windows

Reproducible: Always

Steps to Reproduce:
1. Load page with this html
2. change value
Actual Results:  
Nothing happens

Expected Results:  
Form submit
(Reporter)

Comment 1

13 years ago
Sorry, i mend: On Windows XP and Linux

Comment 2

13 years ago

*** This bug has been marked as a duplicate of 72156 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.