Sunbird crashes if "javascript.options.strict" is set to true

VERIFIED DUPLICATE of bug 319264

Status

()

--
major
VERIFIED DUPLICATE of bug 319264
13 years ago
13 years ago

People

(Reporter: ssitter, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
Sunbird crashes on certain events if "javascript.options.strict" is set to true.

Works with Sunbird 0.3a1+ 2005113006 build.
Fails with Sunbird 0.3a1+ 2005120109 build.

TestCase 1: Steps to Reproduce:

  1. Create new Sunbird profile
  2. Add "user_pref("javascript.options.strict", true);" to your user.js file
  3. Import attached testcase.ics
  --> Sunbird crashes during (or short after) import
  
  4. Change "user_pref("javascript.options.strict", true);" to 
     "user_pref("javascript.options.strict", false);" in your user.js file
  5. Open Sunbird
  --> Sunbird starts, Event is displayed; No error.
  
  6. Close Sunbird
  7. Change "user_pref("javascript.options.strict", false);" back to 
     "user_pref("javascript.options.strict", true);" in your user.js file
  8. Open Sunbird
  --> Sunbird crashes during startup

TestCase 2: Steps to Reproduce:

  1. Create new Sunbird profile
  2. Import attached file testcase.ics
  --> Event is imported and displayed; No error.
  
  3. Close Sunbird
  4. Add "user_pref("javascript.options.strict", true);" to your user.js file
  5. Open Sunbird
  --> Sunbird crashes during startup

  6. Change "user_pref("javascript.options.strict", true);" to 
     "user_pref("javascript.options.strict", false);" in your user.js file
  7. Open Sunbird
  --> Sunbird starts, Event is displayed; No error.

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20051206 Mozilla Sunbird/0.3a1+.
(Reporter)

Comment 1

13 years ago
Created attachment 205156 [details]
testcase.ics
(Reporter)

Comment 2

13 years ago
Also fails with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20051206 Mozilla Sunbird/0.3a1+ running on debian linux.

I used the nightly tinderbox builds that were build with
  ac_add_options --enable-static
  ac_add_options --disable-shared

Potential causers: bug 236617 or 315436.

Comment 3

13 years ago
talkbackid?
Assignee: mostafah → general
Component: General → JavaScript Engine
Product: Calendar → Core
QA Contact: general → general
(Reporter)

Comment 4

13 years ago
(In reply to comment #3)
> talkbackid?

Seems that there is no talkback in Sunbird. I'll try to reproduce with a debug build.
(Reporter)

Comment 5

13 years ago
Created attachment 205298 [details]
callstack after startup crash

Did a debug build based on 2005-12-06 trunk on WinXP.
Attachement shows callstack after Sunbird is restarted with imported event from testcase.ics and js.o.strict set to true.
Hope this helps. I can attach the crash dump file too if needed.
Paging mrbkap!

/be

*** This bug has been marked as a duplicate of 319264 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

13 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.