recurring events do not appear on Sundays in Day, Week and month view or multi week view if they are the top week

RESOLVED WORKSFORME

Status

Calendar
Internal Components
RESOLVED WORKSFORME
13 years ago
12 years ago

People

(Reporter: Tim Naylor, Unassigned)

Tracking

Trunk
x86
Windows XP

Details

Attachments

(2 attachments, 1 obsolete attachment)

329 bytes, text/html
Details
477 bytes, text/plain
Details
(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322; .NET CLR 1.0.3705; .NET CLR 2.0.50727)
Build Identifier: Mozilla Sunbird 0.3a1

This happens on Sundays only (as far as I can tell) only with days that have ' in the name (Mothers' day, Fathers' day, Parents' day but not Easter Morning for example.)
The problem is that in Day view, week view and Month view (first sunday only?)
The Full day event with an ' in the name does not show up in the calendar.
This occurs on Jan 1 of 2006


Reproducible: Always

Steps to Reproduce:
1. Create new calendar
2. Import US holidays from download site
3. open month view and go to January 2006
4. Note that There is no entry for New Year's Day
5. Change to week view of that week
6. Note the same thing
7. Change to Day view of 1/1/2005
8. Note no entry for this all day event
9. Change to Multiweek view with 1/1/2006 on the top
10. Now scroll back one week to include the last week of December
11. Note that this event exists
Actual Results:  
If the item is in the first row. it does not display


Expected Results:  
I would expect events to display

Comment 1

13 years ago
Can we get a testcase ics file please?
Tim: 
If you meant the calendar from http://www.mozilla.org/projects/calendar/caldata/USHolidays.ics it works without problems for me using Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20051104 Mozilla Sunbird/0.3a1.
(Reporter)

Comment 3

13 years ago
I tested on a second computer with this calendar: 
http://www.mozilla.org/projects/calendar/caldata/USHolidays.ics

I used windows XP Pro and 2003 Server Standard.

I was unable to "open" the US holiday calendar in sunbird however I was able to "import" it into my default Home calendar.

By switching from December 2005 to January 2006 in Month view I can see the problem.

1/1/2006 does not show my all day event "New Year's Day" 
Switching directly to Multi week view apears the same

Scrolling "back" one week to include the last week of December my event suddenly appears.

I tested the same calendar on Thunderbird 1.0.7 with calendar_windows_20050111.xpi and did not have the same problem.

I can see the problem on "sunbird-0.3a1.en-US.win32.zip" looks like it was compiled 11/4/2005 about 7:00 am.

As I looked further into the problem this morning I noted that April 2, 2006 (Daylight Savings Time begins) exhibits the same problem although it does not have the special character in the name (Sept 24, 2006 Daylight Savings Time Ends also exhibits it as does Oct 29, 2006 Daylight Savings Time Ends).
(Reporter)

Comment 4

13 years ago
After further research this applies to events that have a recurrance.
Easter in the US Calendar does not use recurrance but has individual enties each year.

All other sunday holidays use recurrance.
I can duplicate this with recurrance using month, year week and day.
I was able to reproduce this with new All day Events in my calendar and events starting before 7:00 am (with the shortest end time of 5 min so 6:55 to 7:00 it failed but 7:00 to 7:05 worked)
Summary: Some events (all day with ' in the name) do not appear on Sundays in Day, Week and month view or multi week view if they are the top week → recurring events do not appear on Sundays in Day, Week and month view or multi week view if they are the top week
(In reply to comment #4)
> I was able to reproduce this with new All day Events in my calendar and events
> starting before 7:00 am (with the shortest end time of 5 min so 6:55 to 
> 7:00 it failed but 7:00 to 7:05 worked)

Please export this testcase event (or events) and post the *.ics file here.

Maybe this is timezone related. What timezone do you live in? GMT-7?

Do you see any error messages in the JavaScript Console?
(Reporter)

Comment 6

13 years ago
Created attachment 205248 [details]
Xmas Day ics file
(Reporter)

Comment 7

13 years ago
Created attachment 205249 [details]
new years ics file
(Reporter)

Comment 8

13 years ago
I attached the files.
I am in SLC, GMT-7
I had not set the option yet so it still read America/new york.
I fixed that and had no change.

I have now tried on 2 additional xp machines with the same result.
This might be the same problem as in bug 315954.

Would you please retry with the last nightly build from http://ftp.mozilla.org/pub/mozilla.org/calendar/sunbird/nightly/2005-12-07-10-trunk/ 
to check if the problem still exist for you?
(Reporter)

Comment 11

13 years ago
I tested this with the dec 7 nightly build on 2 different machines (win2003 and xp)
The result is the same, the defect still exists.

This does not happen in the thunderbird plugin.

Comment 12

13 years ago
Comment on attachment 205248 [details]
Xmas Day ics file

This file isn't helpful.  You need to export it in ics format, not html format.

Note that sunday-allday events work fine for me in month/multiweek views, with the new views.  The week/day views don't support all-day events yet (bug 295387).  I suspect this bug will go away once we switch to the new-views officially.
Attachment #205248 - Attachment is obsolete: true
(Reporter)

Comment 13

13 years ago
Created attachment 205516 [details]
Xmas day ics again
(Reporter)

Comment 14

13 years ago
Here is the ICS version...sorry for the mixup.
It's not like this file is special.  I have reproduced this with 4 different files now.

Actually week view does show all day events in the 12/7/2005 nightly build of sunbird:

Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9a1) Gecko/20051207 Mozilla Sunbird/0.3a1+

The sunday reoccuring events show up 1 week earlier in the weekly view.

Let me go through new reproduction steps so that everyone can understand what I have found

1. create an event on sunday January 1 2006 starting at 6:00 in the morning (yes I do really have an event that starts that early). 
2. View the event in the 1 day view
   Note that it appears normally
3. View the week of the event in Weekly View
   Note that it appears normally
4. View in weekly view with the week in question at the top
   Note that it appears normally
5. View in Monthly view (we chose January 1 2006 because it is a sunday that is the first week of the month).
   Note that it appears correctly in this case
6. Now comes the fun.  Make this a reoccuring appointment (I have reproduced with every 1 year, every 1 month [both first sunday and the 1st of the month], every 1 week, and every 1 day)
7. View in day view
   Note that the event disappears
8. View in week view
   Note that the event does not appear (but if you go back one week it appears)
9. View in multi week with the week in question at the top
   Note that the event does not appear but if you scroll back 1 month it suddenly appears in the correct week.
10. View in month view 
   Note that the event does not appear.
11. For even more fun open in multi week view and scroll back one so that you can edit the event and change it to 7:00.
12 - 14 do the same as 7-10
   Note that in every case the event appears as it should.

All day events are effected because they occur at midnight (which is before 7:00).


I can confirm your error with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20051210 Mozilla Sunbird/0.3a1+ but only if I set my local timezone to GMT-0700 (Mountain Normalzeit).

Seems that this is another view issue based on the timezone settings. We should wait for the new views landing and then see if the problem still exists.
Severity: major → normal
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → Trunk
Tim, do you still have this problem with a current build of sunbird?
http://ftp.mozilla.org/pub/mozilla.org/calendar/sunbird/nightly/latest-trunk/
(In reply to comment #16)
> Tim, do you still have this problem with a current build of sunbird?

No response from reporter. All the above testcases work for me now.
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060302 Mozilla Sunbird/0.3a1+
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
The bugspam monkeys have struck again. They are currently chewing on default assignees for Calendar. Be afraid for your sanity!
Assignee: base → nobody
You need to log in before you can comment on or make changes to this bug.