textarea div on top of overflow:auto div does not display caret

RESOLVED DUPLICATE of bug 167801

Status

()

defect
RESOLVED DUPLICATE of bug 167801
14 years ago
14 years ago

People

(Reporter: curzio, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.0.3705; .NET CLR 1.1.4322)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

This textarea won't display the caret. It works if you don't put overflow:auto in the first div...

<div style="top:100;left:100;width:200;height:200; background-color:black; position:absolute;z-Index:1;overflow:auto;"></div>
   <div style="top:150;left:150;width:100;height:100; background-color:black; position:absolute;z-Index:2;"><textarea   style="width:100%;height:100%;border:0">asd</textareA></div> 

Reproducible: Always

Steps to Reproduce:
1. make a div with overflow:auto
2. make another div on top of it with a text area inside
3. click on text area... no caret




Display the caret normally.

Comment 1

14 years ago
Duplicate of bug 295437 -> Core bug 223239 -> Core bug 167801?

Comment 2

14 years ago
This also happens on text boxes as well as text areas.  If you make overflow:hidden on the underlying layer, the cursor re-appears.  

*** This bug has been marked as a duplicate of 167801 ***
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.