Entering a new URL in the location bar fails since pressing 'Enter' is treated as input on current page

RESOLVED DUPLICATE of bug 319306

Status

()

Firefox
General
--
minor
RESOLVED DUPLICATE of bug 319306
12 years ago
12 years ago

People

(Reporter: TheAngulion, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

I was on the web page of my mail provider (webmail.1und1.de) which contains two text entry fields for user name and password. I then tried to go to another URL by typing the new address in the location bar and pressing 'Enter'. However, pressing the 'Enter' key was somehow directed to the form field on the current web page. So instead of going to a new URL I ended up submitting the form data which resulted in a login error message and left me at the same web page I started at.
I am pretty positive that this problem is new to the 1.5 version of Firefox since I had not encountered it so far.

Reproducible: Always

Steps to Reproduce:
1. Open webmail.1und1.de
2. Type any other URL in the location bar and hit 'Enter'.


Actual Results:  
Instead of going to the new URL you should still be on webmail.1und1.de and see an error message saying that login failed.

Expected Results:  
Expected to open new URL in current window.
See Bug 319306.
(Reporter)

Comment 2

12 years ago
Hi Ria,
thanks for pointing out the previously reported bug which indeed describes the very same problem I face. Before originally posting I did search the forum for similar posts but did not come across the bug you now mentioned.
sorry and thanks,
Andi

Comment 3

12 years ago
Interesting. On Firefox 1.5 in Windows XP SP1, all updates except SP2, this does not happen. Clicking on entry forms and entering data and then going to other URL's does not bring up the error you describe; Firefox correctly navigates to the URL entered.
(Reporter)

Comment 4

12 years ago
Update to my original posting:
For some reason I cannot reproduce the error I reported. Right now, everything is working as it is supposed to be (just as Patrick wrote). Maybe my mail provider changed the homepage? ... frankly, I am a little puzzled.
cheers,
Andi
Yes, the webmaster must have fixed it.

Comment 6

12 years ago
With respect to FireFox versions 1.5.0.2 and 1.5.0.3 - When initially opening FireFox and the start page loads, the URL will not act on typed in or pasted URL links.  This is a very severe problem. I have been able to get around this by:
1) right clicking on the toolbar area and selecting customize
2) removing the URL bar back into the icon window
3) replace the icon back to the toolbar

Now it will work unt

Comment 7

12 years ago
Duping with bug 319306.

Regarding comment #6:

David -  interesting issue, however, you will need to file a separate bug since it is most likely to be unrelated.
For more info, you may read the Bug Writing Guidelines at <http://www.mozilla.org/quality/bug-writing-guidelines.html> to see the kinds of information we need in a bug report. Please report back with more information (like BuildID and steps to reproduce) after reading those guidelines and consider using the guided form to report future bugs. 
The guided entry form can be found at <https://bugzilla.mozilla.org/enter_bug.cgi?format=guided> 


*** This bug has been marked as a duplicate of 319306 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.