Closed Bug 319422 Opened 15 years ago Closed 15 years ago

Quoted Printable From Addresses with "," display incorrectly and creates failures during reply

Categories

(Thunderbird :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 254519

People

(Reporter: florian, Assigned: mscott)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; de; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Version 1.5 (20051025)

I create a User account as

Name: Dürr, Sören
eMail: Soeren.Duerr@domain.com

I send an email to myself.

In my send items as well as my inbox i see

From: Sören <Soeren.Duerr@domain.com>

When I hit reply, the email is supposed to be sent to the above and also do

Duerr

So the "," in the From address is treated as a separator character even though it is encoded in ISO-8859-1 as =2C



Reproducible: Always

Steps to Reproduce:
see above



This is super-annoying in German language environments where last, first is a common form of the firendly name.
Duplicate of bug 310547 and/or Core bug 254519?
Yes, a dupe.

*** This bug has been marked as a duplicate of 254519 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.