If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

unreproducable crash opening link in new background tab [@ 0x00030340 7d257d14] access violation

VERIFIED DUPLICATE of bug 322700

Status

()

Firefox
General
--
critical
VERIFIED DUPLICATE of bug 322700
12 years ago
6 years ago

People

(Reporter: tonymec, Unassigned)

Tracking

({crash})

1.5.0.x Branch
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051206 Firefox/1.5
Build Identifier: "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051206 Firefox/1.5", build ID:2005120604

TB12692927H


Reproducible: Didn't try

Steps to Reproduce:

Actual Results:  
crash

Expected Results:  
no crash

TB report follow. Please disregard the "URL visited", it is a leftover from the previous crash.

Stack Signature	 0x00030340 7d257d14
Product ID	Firefox15
Build ID	2005120604
Trigger Time	2005-12-07 01:20:42.0
Platform	Win32
Operating System	Windows NT 5.1 build 2600
Module	
URL visited	http://en.wikipedia.org/w/index.php?title=DeviantART&diff=30341133&oldid=29585591
User Comments	opening a link in a new "background (i.e., non-focused) tab
Since Last Crash	11826 sec
Total Uptime	29312 sec
Trigger Reason	Access violation
Source File, Line No.	N/A
Stack Trace 	
0x00030340
js_GetSlotThreadSafe  [c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/js/src/jslock.c, line 554]
JS_GetPrivate  [c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/js/src/jsapi.c, line 2141]
XPC_NW_NewResolve  [c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/js/src/xpconnect/src/XPCNativeWrapper.cpp, line 847]
js_LookupPropertyWithFlags  [c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/js/src/jsobj.c, line 2675]
js_LookupProperty  [c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/js/src/jsobj.c, line 2580]
js_GetProperty  [c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/js/src/jsobj.c, line 2865]
js_Interpret  [c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/js/src/jsinterp.c, line 5249]
js_Invoke  [c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/js/src/jsinterp.c, line 1197]
nsXPCWrappedJSClass::CallMethod  [c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/js/src/xpconnect/src/xpcwrappedjsclass.cpp, line 1369]
nsXPCWrappedJS::CallMethod  [c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/js/src/xpconnect/src/xpcwrappedjs.cpp, line 462]
SharedStub  [c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp, line 147]
nsEventListenerManager::HandleEventSubType  [c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/content/events/src/nsEventListenerManager.cpp, line 1685]
nsEventListenerManager::HandleEvent  [c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/content/events/src/nsEventListenerManager.cpp, line 1786]
nsXULElement::HandleDOMEvent  [c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/content/xul/content/src/nsXULElement.cpp, line 2153]
nsXULElement::HandleDOMEvent  [c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/content/xul/content/src/nsXULElement.cpp, line 2174]
nsXULElement::HandleDOMEvent  [c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/content/xul/content/src/nsXULElement.cpp, line 2174]
nsXULElement::HandleDOMEvent  [c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/content/xul/content/src/nsXULElement.cpp, line 2174]
nsXULElement::HandleDOMEvent  [c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/content/xul/content/src/nsXULElement.cpp, line 2174]
nsXULElement::HandleDOMEvent  [c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/content/xul/content/src/nsXULElement.cpp, line 2174]
nsXULElement::HandleChromeEvent  [c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/content/xul/content/src/nsXULElement.cpp, line 2833]
nsGlobalWindow::HandleDOMEvent  [c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/dom/src/base/nsGlobalWindow.cpp, line 1574]
nsDocument::HandleDOMEvent  [c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/content/base/src/nsDocument.cpp, line 4013]
nsEventStateManager::DispatchNewEvent  [c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/content/events/src/nsEventStateManager.cpp, line 4554]
nsDocument::DispatchEvent  [c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/content/base/src/nsDocument.cpp, line 4097]
nsDocument::DispatchContentLoadedEvents  [c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/content/base/src/nsDocument.cpp, line 2213]
nsHTMLDocument::EndLoad  [c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/content/html/document/src/nsHTMLDocument.cpp, line 983]
HTMLContentSink::DidBuildModel  [c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/content/html/document/src/nsHTMLContentSink.cpp, line 2203]
CNavDTD::DidBuildModel  [c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/parser/htmlparser/src/CNavDTD.cpp, line 604]
Keywords: crash
Version: unspecified → 1.5 Branch

Comment 1

12 years ago
fwiw, that's a known talkback bug (the stale url).
(In reply to comment #1)
> fwiw, that's a known talkback bug (the stale url).
> 

Yeah, I know; but since I don't use talkback auto-forwarding (i.e., I look at the talkback form before sending), I should have blanked the URL type-in box -- only I forgot, so I'm mentioning here in comment #0 that the URL mentioned here is invalid. ;-)

This bug 319423 is not about talkback anyway (that's a minor annoyance, not a critical bug), but about Firefox (access violation crash).

-- 
Best regards,
Tony.

Comment 3

12 years ago
any more of a test case to go on than "opening a link in a new "background (i.e., non-focused) tab"?

Updated

12 years ago
Summary: crash [@ 0x00030340 7d257d14] access violation → unreproducable crash opening link in new background tab [@ 0x00030340 7d257d14] access violation

Comment 4

12 years ago
I've been running across similar instances of this bug report. This problem has
been occurring off and on for several months (with and before Firefox 1.5;
current build is 20060111). Most often it will crash on any instance of opening
a new tab (Ctrl+T, Right mouse click context menu on page or bookmark, link in
a TBird email, etc.) or searching the page content using Ctrl+F or just typing the text. Very difficult to reproduce and none of the instances seem to have something in common (at least from what I can tell).

Here are some Talkback Incident IDs along with the comments:
TB16397809G - Opening a new tab
TB16494674G - Pressed Ctrl+T
TB17004279E - Clicking on link that opened up pop-up window
TB17004506W - Clicked on link to open a Word doc
TB17014681Q - Pressed Ctrl+F to search text of a page
TB17056975E - Clicked link which opened pop-up window
TB17058696E - Clicked button on page which normally causes a confirmation dialog (Are you sure? (Yes/No)) but Firefox crashed
TB17084836E - finding text on page

For the last 3, I have output from windbg using the command "!analysis -v". Unfortunately, I don't have a build with the debugging symbols that would make this helpful. If I can be of further assistance let me know. 

*** This bug has been marked as a duplicate of 322700 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Updated

12 years ago
Status: RESOLVED → VERIFIED
(Assignee)

Updated

6 years ago
Crash Signature: [@ 0x00030340 7d257d14]
You need to log in before you can comment on or make changes to this bug.