Recurring events show initial date in Event bar when selected instead of the recurrance date

VERIFIED FIXED

Status

Calendar
General
VERIFIED FIXED
13 years ago
12 years ago

People

(Reporter: Tim Naylor, Unassigned)

Tracking

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9a1) Gecko/20051104 Mozilla Sunbird/0.3a1

After installing a calendar with recurring events (like US hollidays).  When you Select an event the "event bar" synchronizes with that event.  If you choose an occurance of the event after the initial occurance the sync goes to the initial occurance not the correct recurrance.

Reproducible: Always

Steps to Reproduce:
1. Import the usholidays calender faound here: http://www.mozilla.org/projects/calendar/caldata/USHolidays.ics 
2. Select the next recurring holiday (Christmas Day probably)
3. Note that the Event bar syncs to Sun Dec 24 2000-Mon Dec 25, 2000 instead of  Sat Dec 24, 2005- Sun Dec 25, 2005. 

Actual Results:  
Sync to initial date in the recurring event instead of the occurance.

Expected Results:  
Sync to specific occurance.

Updated

13 years ago
OS: Windows Server 2003 → All
Hardware: PC → All

Comment 1

13 years ago
I can confirm this with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060404 Mozilla Sunbird/0.3a1+

Some additional info: your filtering settings on the event bar influence the bug.  If you select 'show all events' then clicking a holiday sets the event highlight to the initial time the event is in the database (25 Dec 2000 for the Christmas example provided above.)  Selecting a more restrictive event filter, such as 'events in the next 14 days' causes the event to not be highlighted at all, because as far as the database is apparently concerned, the event *happened* already and thus isn't within the filtering limits... even if it happens again within the next 14 days and should otherwise show up in the filter.  (Plus, if you select 'show all events' and scroll through the list, the event is listed on each recurrence, so the events list at least knows how to parse that much.)

So to summarize the additional info:

Reproducible: Always

Steps to Reproduce: See above.  Note that in 'show all events' filter, 25 Dec 2006 comes up as Christmas.  Now change event filtering to 'all future events', then select Christmas 2006 in calendar.

Actual result:
No event is highlighted in the future events list.

Expected result:
Christmas Day 25 Dec 2006 should be highlighted in events list.
Assignee: mostafah → nobody
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → Trunk

Comment 2

12 years ago
Is this a duplicate of bug 299651 ?
  ('all events' shows just the events .. other views shows occurences.)

As noted (bug 299651): The unifinder ('events list' bar) could EITHER include all occurrences (including multiple), OR have the start column show distinct details for multi-occurrence events.
(Reporter)

Comment 3

12 years ago
No this is not the same as 296551 - 
The gist of this defect is that all day events get pushed a week earlier in some views (in the view they occur) such as month, week, and multiweek views.  
I have verified that it is working properly (has been resolved for Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20051104 Mozilla GREAT JOB!  

I have also verified it fixed on:
Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9a1) Gecko/20051104 Mozilla Sunbird/0.3a1


unfortunately the new issue may still exist.  it is different in some way and therefore should be reissued as a new defect
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
(Reporter)

Updated

12 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.