Crash when clicking on blank area - images blocked - JavaScript disabled [@ GetSelectionClosestFrameForChild]

RESOLVED FIXED

Status

()

Core
Selection
--
critical
RESOLVED FIXED
12 years ago
7 years ago

People

(Reporter: Tom Cathey, Assigned: Adam Guthrie)

Tracking

({crash, regression})

Trunk
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.9a1) Gecko/20051208 Firefox/1.6a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051208 Firefox/1.6a1



Reproducible: Always

Steps to Reproduce:
Disable JavaScript (Uncheck enable JavaScript)
Go to https://webauth.att.net/auth/webmail/login
(Login NOT required).
Right-click on the large ad image and block images from webauth.att.net

Clear cache, close and then reopen Deer Park
Go to the same URL
Left-click anywhere on the LEFT of the screen in the blue area.

Observe crash.

No crash if images are not blocked and/or JavaScript enabled.

Same results when conducted in Safe Mode.

NO crash with 2005120705
   Crash with 2005120800
   Crash with 2005120805 -- TB12739788K 12/8/2005 10:11 AM EST

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051208 Firefox/1.6a1
Actual Results:  
Crash - TB12739788K 12/8/2005 10:11 AM EST
(Assignee)

Comment 1

12 years ago
Incident ID: 12739788
Stack Signature	GetSelectionClosestFrameForChild 8a531ae2
Product ID	FirefoxTrunk
Build ID	2005120805
Trigger Time	2005-12-08 07:11:25.0
Platform	Win32
Operating System	Windows NT 5.1 build 2600
Module	firefox.exe + (001a13c9)
URL visited	https://webauth.att.net
User Comments	JaveScript disabled. Images blocked. Left-click on left of screen in blue area.
Since Last Crash	567 sec
Total Uptime	567 sec
Trigger Reason	Access violation
Source File, Line No.	c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/generic/nsFrame.cpp, line 1828
Stack Trace 	
GetSelectionClosestFrameForChild  [c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/generic/nsFrame.cpp, line 1828]
GetSelectionClosestFrame  [c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/generic/nsFrame.cpp, line 2058]
GetSelectionClosestFrameForChild  [c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/generic/nsFrame.cpp, line 1830]
GetSelectionClosestFrame  [c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/generic/nsFrame.cpp, line 2058]
GetSelectionClosestFrameForChild  [c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/generic/nsFrame.cpp, line 1830]
GetSelectionClosestFrame  [c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/generic/nsFrame.cpp, line 2058]
GetSelectionClosestFrameForChild  [c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/generic/nsFrame.cpp, line 1830]
GetSelectionClosestFrame  [c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/generic/nsFrame.cpp, line 2058]
GetSelectionClosestFrameForChild  [c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/generic/nsFrame.cpp, line 1830]
GetSelectionClosestFrame  [c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/generic/nsFrame.cpp, line 2058]
GetSelectionClosestFrameForChild  [c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/generic/nsFrame.cpp, line 1830]
GetSelectionClosestFrameForLine  [c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/generic/nsFrame.cpp, line 1913]
GetSelectionClosestFrameForBlock  [c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/generic/nsFrame.cpp, line 1984]
GetSelectionClosestFrame  [c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/generic/nsFrame.cpp, line 2004]
nsFrame::GetContentAndOffsetsFromPoint  [c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/generic/nsFrame.cpp, line 2113]
nsFrame::HandlePress  [c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/generic/nsFrame.cpp, line 1297]
nsFrame::HandleEvent  [c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/generic/nsFrame.cpp, line 979]
PresShell::HandleEventInternal  [c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/base/nsPresShell.cpp, line 6052]
PresShell::HandleEvent  [c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/base/nsPresShell.cpp, line 5863]
nsViewManager::HandleEvent  [c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/view/src/nsViewManager.cpp, line 2545]
nsViewManager::DispatchEvent  [c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/view/src/nsViewManager.cpp, line 2237]
HandleEvent  [c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/view/src/nsView.cpp, line 176]
nsWindow::DispatchEvent  [c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/widget/src/windows/nsWindow.cpp, line 1162]
nsWindow::DispatchMouseEvent  [c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/widget/src/windows/nsWindow.cpp, line 6007]
ChildWindow::DispatchMouseEvent  [c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/widget/src/windows/nsWindow.cpp, line 6213]
nsWindow::WindowProc  [c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/widget/src/windows/nsWindow.cpp, line 1351]
USER32.dll + 0x8734 (0x77d48734)
USER32.dll + 0x8816 (0x77d48816)
USER32.dll + 0x89cd (0x77d489cd)
USER32.dll + 0x8a10 (0x77d48a10)
nsAppShell::Run  [c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/widget/src/windows/nsAppShell.cpp, line 159]
nsAppStartup::Run  [c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/toolkit/components/startup/src/nsAppStartup.cpp, line 162]
main  [c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/browser/app/nsBrowserApp.cpp, line 61]
kernel32.dll + 0x16d4f (0x7c816d4f)
Severity: normal → critical
Component: General → Layout: HTML Frames
Keywords: crash
Product: Firefox → Core
QA Contact: general → layout.html-frames
Summary: Crash when clicking on blank area - images blocked - JavaScript disabled → Crash when clicking on blank area - images blocked - JavaScript disabled [@ GetSelectionClosestFrameForChild]
Version: unspecified → Trunk
(Reporter)

Comment 2

12 years ago
On second thought, is this possibly related to or a duplicate of...
Bug 319503 - Crash when viewing Tinderbox
(Assignee)

Updated

12 years ago
(Assignee)

Updated

12 years ago
(Assignee)

Comment 3

12 years ago
(In reply to comment #2)
> On second thought, is this possibly related to or a duplicate of...
> Bug 319503 - Crash when viewing Tinderbox

Sure does. :(


*** This bug has been marked as a duplicate of 319503 ***
No longer blocks: 316281
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Component: Layout: HTML Frames → Selection
Resolution: --- → DUPLICATE
(Assignee)

Updated

12 years ago
Blocks: 316281
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 4

12 years ago
Two reliable ways I've noticed to get this crash are:
On http://tinderbox.mozilla.org/Firefox/
Click on any empty table area like the guilty column or a gray area.

On http://talkback-public.mozilla.org/talkback/fastfind.jsp
Start selecting with the word quicksearch and keep selecting more of the page going downward.  

Updated

12 years ago
Assignee: nobody → ispiked
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

12 years ago
layout/generic/nsFrame.cpp:
2057     if (closestFrame);

Oops.

Fixed.
Status: NEW → RESOLVED
Last Resolved: 12 years ago12 years ago
OS: Windows XP → All
Hardware: PC → All
Resolution: --- → FIXED
*** Bug 319503 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 7

12 years ago
*** Bug 319595 has been marked as a duplicate of this bug. ***

Comment 8

12 years ago
Thanks to everyone who dealt with this; sorry for the inconvenience.
*** Bug 319621 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 10

12 years ago
*** Bug 319721 has been marked as a duplicate of this bug. ***

Comment 11

12 years ago
*** Bug 319750 has been marked as a duplicate of this bug. ***

Comment 12

12 years ago
Can anyone tell me why I get the message "C is not a proper Protocol" and images are not displayed?
Crash Signature: [@ GetSelectionClosestFrameForChild]
You need to log in before you can comment on or make changes to this bug.