Cannot use letter keys to select folders in the "File"/"Move To"/"Copy To" folder tree menu

RESOLVED DUPLICATE of bug 226874

Status

RESOLVED DUPLICATE of bug 226874
13 years ago
10 years ago

People

(Reporter: davisc, Unassigned)

Tracking

PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Thunderbird 1.5 (Macintosh/20051025)

In TB 1.5RC1 on Mac OS X Tiger (10.4.3).  After accessing the folder tree menu using either the toolbar "File" command or the context menu "Move To" or "Copy To" command, one cannot use letter keys to select folders.  If you access the folder tree menu  using the either the menubar "Message > Move" or "Message > Copy" commands, pressing letter keys will select folders with names that match the sequence of keys typed.

This function is working in the Windows release on Windows XP, though it will only cycle through folders that start with the pressed letter.

Reproducible: Always

Steps to Reproduce:
1. Select a message in your INBOX
2. Click the toolbar "File" command.
3. Press letter keys to select the account and folder to move the message to.

or

1. Select a message in your INBOX
2. Ctrl+Click the message and select the contextmenu "Move To" or "Copy To" command.
3. Press letter keys to select the account and folder to move the message to.
Actual Results:  
No account or folder is selected.

Expected Results:  
The sequence of keys pressed should select a folder whose name starts with that sequence.  This works properly for the menubar "Message > Move" or "Message > Copy" commands. 

This was requested in bug 226874; it seems to be partially implemented in TB 1.5 RC1 on Mac OS.
(Reporter)

Updated

13 years ago
Version: unspecified → 1.5

Comment 1

12 years ago
don't know if i understood this one wrong, but when there is similar access keys (the underlined ones) in the context menu (right mouse click), the sub-menu don't open.

attached i've made a screenshot from an imap folder. pressing keyboard 'M' for 'Move To', the sub-folder I have doesn't open, so I have to press <enter>.

that is not a big deal, but it's kind of annoying and used to work with TB 1.5*. Have this problem with TB 2.0 B1 and B2 (version 2 beta 2 (20070116))

Comment 2

12 years ago
Created attachment 252607 [details]
context menu with similar access keys
QA Contact: front-end

Comment 3

11 years ago
Ludovic do you see this?

Comment 4

10 years ago
JOe, do you see this?
Assignee: mscott → nobody

Comment 5

10 years ago
Tested in WinXp (works fine)
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1pre) Gecko/2008062703 Thunderbird/3.0a2pre ID:2008062703
And
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.16pre) Gecko/20080624 Lightning/0.8 Thunderbird/2.0.0.16pre ID:2008062403

Where multiple (duplicate) keys are available, depressing the key again moves to the next selection.

Comment 6

10 years ago
Jay, do you see this?
In: version 3.0a2pre (2008062703)

Depending on how you interpret the original report... it may not work as described. Basically I can type the FIRST LETTER of an Account Name, and it will open that Account (I have "Work" and "Local" for example, pressing "W" opens up the Work folders automatically and displays a list of folders. I can then press "D" and it takes me to the Drafts folder. If I press "D" again, it takes me to the Deleted folder.

However, reading the original report... it looks like in the Windows version you can type "DE" and go straight to the Deleted folder. That definitely sounds better to me, but if it doesn't work that way on MacOSX, then I guess it is ok, but do believe the other way is better. Of course, change in functionality not being desirable is a consideration.

Personally I use the "Nostalgy" plug-in to do my copying and saving of messages since SHIFT-COMMAND-M starts a new message instead of actually MOVING the message like the Drop Down menu says it does.

Anyway, if you're supposed to be able to type more letters to qualify the folder, that is NOT working. If you're just supposed to type the FIRST character multiple times to move between folders, then that works.

Comment 8

10 years ago
The "Nostalgy" plug-in is indeed what i was dreaming of. Hope it works right in the first day of the upcoming TB release.

Comment 9

10 years ago
comment 0 reads like simply a dupe of bug 226874
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 226874
You need to log in before you can comment on or make changes to this bug.