Closed Bug 319681 Opened 14 years ago Closed 14 years ago

Cannot delete location/description of event

Categories

(Calendar :: Internal Components, defect)

x86
Windows 2000
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: mozilla, Assigned: jminta)

References

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

When an event has a value for the "location" field, it can be changed to a different value, but not deleted.

Reproducible: Always

Steps to Reproduce:
1. Create an event with any value for "location", or add a location to an existing event.
2. Edit the event and delete the location.  Press OK.


Actual Results:  
The original value for the location remains.

Expected Results:  
The location should have been deleted.

in Sunbird 0.3a1
Confirmed with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051208 Mozilla Sunbird/0.3a1+.

It is not possible to delete the value of the location and description field for events and tasks. No errors in javascript console.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Cannot delete location of event → Cannot delete location/description of event
Version: unspecified → Trunk
Also confirmed with Gecko/20051208 Mozilla Thunderbird/1.6a1 + Lightning.
It is not possible to delete the content of the location/url/attendees/description field. (It is possible to delete the content of the title field as in sunbird)
-> me
Assignee: base → jminta
Attached patch sunbird patchSplinter Review
Deletes the property if there isn't any value specified.  The idl states that this is acceptable to do, even if the property wasn't set before, and testing confirms this.

calendar-event-dialog.js does this in a much nicer way, with helper functions, etc.  We really do need to look into moving to that for Sunbird.

The lightning manifestation of this problem is the result of a failure to add an observer to the composite.  The fix for this is included in the new-views patch, and hence will not be included here.
Attachment #205445 - Flags: first-review?(mvl)
Comment on attachment 205445 [details] [diff] [review]
sunbird patch

r=mvl
Attachment #205445 - Flags: first-review?(mvl) → first-review+
sunbird patch checked in.  Adding dependency on the new-views, since that ought to fix things in lightning.
Depends on: 297934
Changing resolution to FIXED as it now also works with Lightning.
Tested successfully in Thunderbird 1.6a1 + Lightning (20060108).
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.