Deer Park and Firefox, and default browser settings

RESOLVED DUPLICATE of bug 330326

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 330326
13 years ago
12 years ago

People

(Reporter: Berkana, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051118 Firefox/1.5
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051118 Firefox/1.5

I have set the G5 optimized version of Firefox as my default browser, but when I double click on files or links in my mail application, Firefox (the non-G5 optimized version) launches, and without opening the file, nor opening the links I click.

Reproducible: Always

Steps to Reproduce:
1. Either click on a link in e-mail or
2. double click on an HTML file
3. Watch Firefox open and do nothing.

Actual Results:  
Firefox opens, but not the version I set as my default browser (which should be "deer park", the G5 optimized version). The browser launches, but doesn't open the file I double clicked on, nor does it launch the link I click on. Instead, it just opens to the home page.

Expected Results:  
I expected double clicking on HTML files with the Firefox HTML icon to at least open the page, in Firefox if not "deer park". I expected clicking on links to open the link, not just launching the browser.

This seems to be consistent behavior. Also, I set "Deer Park" to be my default browser from the Deer Park preferences.

Comment 1

12 years ago
This is actually a Mac OS X bug that's been around since at least 10.2. For example, see bug 299833. It's been reported to Apple before, with no luck.

I've just opened a tech evangelism bug about it, in case someone there can do anything -> bug 330326.

*** This bug has been marked as a duplicate of 330326 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.