Closed Bug 319767 Opened 15 years ago Closed 15 years ago

SVG tspan baseline-shift="super" not rendered as superscript

Categories

(Core :: SVG, defect)

1.8 Branch
x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 308338

People

(Reporter: david.strozzi, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051209 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051209 Firefox/1.5

Firefox does not correctly render SVG superscripts defined via the construct 
a<tspan baseline-shift="super">b</tspan>c.
However, the adobe plugin for Internet Explorer does get it right.
Firefox doesn't give an error, it just puts abc on the same line (instead of raising b).

A complete .svg file that demonstrates the problem is:

<?xml version="1.0" standalone="no"?><!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 1.1//EN" "http://www.w3.org/Graphics/SVG/1.1/DTD/svg11.dtd">
<svg version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink">
<text x="100.000" y="100.000">a<tspan baseline-shift="super">3</tspan>b</text>
</svg>


Thanks for looking into this,
David STrozzi

Reproducible: Always

Steps to Reproduce:
1. save the .svg text included above to a file.
2. open it with firefox.
3. the b is not raised above a and c.

Actual Results:  
Everything is rendered, but a b and c are on the same line.  b should be raised, as it is in IE with the Adobe svg plugin.

Expected Results:  
b should be higher than a and c
Duplicate of Core bug 308338?
Assignee: nobody → general
Component: General → SVG
Product: Firefox → Core
QA Contact: general → ian
Version: unspecified → 1.8 Branch
(In reply to comment #1)
> Duplicate of Core bug 308338?
> 

Yes, it is.  Sorry about that!

*** This bug has been marked as a duplicate of 308338 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.