crash after playing a (broken?) swf file [@ ntdll.dll + 0x10f29]

RESOLVED WORKSFORME

Status

External Software Affecting Firefox
Flash (Adobe)
--
critical
RESOLVED WORKSFORME
12 years ago
7 years ago

People

(Reporter: Eyal Rozenberg, Unassigned)

Tracking

({crash, regression})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

59.27 KB, application/x-shockwave-flash
Details
(Reporter)

Description

12 years ago
I got this flash file from Google, which I saved to disk (it doesn't do much, I guess they tied it in to the original page: 

http://video.google.com/videoplay?docid=7820333450116505275&q=shingo

). Anyway, whenever I:

1. Open seamonkey
2. Open the swf file (from the HDD)
3. Press Play
4. Wait 2 seconds
5. Close Seamonkey

I get a crash. Talback ID: TB12802435K . Stack:

ntdll.dll + 0x10f29 (0x7c910f29)
ntdll.dll + 0x10d5c (0x7c910d5c)
msvcrt.dll + 0x1c2de (0x77c2c2de)
operator delete

Of course, this may be a Windows bug, or a flash plugin bug, but maybe it could be worked around somehow.
(Reporter)

Comment 1

12 years ago
Created attachment 205470 [details]
offending flash file

This is the flash file which triggers the crash. Download it to your local disk first.

PS - Was using sm trunk build 2005-11-30.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051209 Firefox/1.6a1 ID:2005120917

Can't reproduce a crash on Firefox trunk and branch builds. It closes properly.
Using flash 8.0 r22.
(Reporter)

Comment 3

12 years ago
(In reply to comment #2)
> Using flash 8.0 r22.
> 
Same here.

(Reporter)

Updated

12 years ago
Keywords: crash, regression, talkbackid

Comment 4

12 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20051210 Firefox/1.6a1

Works for me with Shockwave Flash 7.0 r25. Is there a reason you think this is a regression? When did it regress?
Severity: normal → critical
Keywords: talkbackid
Summary: crash after playing a (broken?) swf file → crash after playing a (broken?) swf file [@ ntdll.dll + 0x10f29]
(Reporter)

Comment 5

12 years ago
> Works for me with Shockwave Flash 7.0 r25. Is there a reason you think this is
> a regression?

Yeah, it WFM with the last mozilla trunk build (2005-07-02).

Comment 6

11 years ago
closing
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME

Updated

8 years ago
Component: Plug-ins → Flash (Adobe)
Product: Core → Plugins
QA Contact: plugins → adobe-flash
Version: Trunk → unspecified
(Assignee)

Updated

7 years ago
Crash Signature: [@ ntdll.dll + 0x10f29]
You need to log in before you can comment on or make changes to this bug.