Can't from preferences set search to google.co.uk

RESOLVED WONTFIX

Status

--
minor
RESOLVED WONTFIX
13 years ago
10 years ago

People

(Reporter: joanna.j, Unassigned)

Tracking

1.7 Branch
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.12) Gecko/20050915
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.12) Gecko/20050915

Now that google is heavily localized, not having the search button take you to your local google seriously changes the values of the search.  For example "hop pole bath" will take me to the phone number of the hop pole in bath on one click from google.uk, but will just give me a bunch of review sites in google.com

Reproducible: Always

Comment 1

13 years ago
This seems to work for me with SeaMonkey 1.0a: go to http://mycroft.mozdev.org/quick/google.html, choose the "Google UK - The Web" (or  "Google UK - pages from the UK") search plugin under "6. General" and set Google UK as default search engine in the Navigator > Internet Search preferences.
(Reporter)

Comment 2

13 years ago
OK, that works -- but *how* are you supposed to know to do that?  There is no information in the help or on the preferences panel to indicate that that is a plugin.  Perhaps the preferences panel for search (which has plenty of room on it) could suggest going to that page to add further search options?
MozillaAS v1.7.x is not supported anymore.

Can you reproduce with SeaMonkey v1.1.9 ?
Version: unspecified → 1.7 Branch

Comment 4

10 years ago
(In reply to comment #3)
> MozillaAS v1.7.x is not supported anymore.
> 
> Can you reproduce with SeaMonkey v1.1.9 ?
> 

Of course it's the same. The problem is that you need the Google UK plugin in order to be able to choose from the list of search-plugins. If you use a en-US version of seamonkey, having Google UK doesn't really makes sense. The en-UK verson of seamonkey should have Google UK, though (and I think it has). I'm going to mark this as invalid for that reason. We might consider a few lines in Help, though.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
(Reporter)

Comment 5

10 years ago
Hi -- Please read the full conversation above.  From early on in Seamonkey (2005-12-11) I said it *could* work, and suggested that there be more information on the "set search" panel under preferences so you could realize that it should in fact be added as a plug in.  From that point is was a usability bug, not an actual functionality bug. 

Anyway, in the intervening time, Google itself has been addressing a lot of this (if you don't mind a ton of cookies.)
Resolution: INVALID → WONTFIX
You need to log in before you can comment on or make changes to this bug.