Status

()

Core
Layout
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: Mariano Suarez Alvarez, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051201 Fedora/1.5-1.1.fc4.nr Firefox/1.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051201 Fedora/1.5-1.1.fc4.nr Firefox/1.5

The two xhtml files in the attached tar.gz are rendered quite differently by "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051201 Fedora/1.5-1.1.fc4.nr Firefox/1.5", while the difference between them should not have that effect.

good.html is rendered with a reasonable amount of white space at the end.
bad.html has almost a screenful of white space there.

The only difference between the two files is that bad.html has an extra <li> element in the <ul> in the #news div.

I imagine that the difference in the rendering of these files is a bug.

Reproducible: Always

Steps to Reproduce:
(Reporter)

Comment 1

13 years ago
Created attachment 205517 [details]
.tar.gz containing an example

Here goes a test case.

Comment 2

13 years ago
the float containing the validator buttons has "margin-bottom: 50%".  ????

from http://www.w3.org/TR/CSS21/box.html#margin-properties
<percentage>
    The percentage is calculated with respect to the width of the generated box's containing block. Note that this is true for 'margin-top' and 'margin-bottom' as well.

Based on that, it should have the large blank area at the bottom.  The reason it doesn't sometimes is bug 249982.

Resolving INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.