No background color and broken border for absolute-positioned elements outside viewport

RESOLVED WORKSFORME

Status

()

Core
Layout
RESOLVED WORKSFORME
12 years ago
12 years ago

People

(Reporter: ad, Unassigned)

Tracking

({testcase})

1.0 Branch
x86
Linux
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

676 bytes, text/html
Details
(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Firefox/1.0.7 (Debian package 1.0.7-1)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Firefox/1.0.7 (Debian package 1.0.7-1)

An element with the position: absolute; property and a large top and left value (must be greater then the size of the browser window) will not be rendered with a background-color and only with a broken border, event if the user scrolls far enough to see it.

(see testcase)

Reproducible: Always

Steps to Reproduce:
1. create element with a background color, position absolute, and top: 3000px; left: 3000px
2. scroll to element


Actual Results:  
element does not have background color and a broken border

Expected Results:  
element should look normally (see testcase)
(Reporter)

Comment 1

12 years ago
Created attachment 205656 [details]
testcase, does not work for me
(Reporter)

Comment 2

12 years ago
Created attachment 205657 [details]
better testcase

sorry, bad testcase. forgot to set the background color on body (since my default isn't white). try this one.
Attachment #205656 - Attachment is obsolete: true

Comment 3

12 years ago
Please retest with Firefox 1.5
Component: General → Layout
Product: Firefox → Core
QA Contact: general → layout
Version: unspecified → 1.0 Branch

Comment 4

12 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20051227 Firefox/1.6a1

This works for me in the latest trunk. Reopen if you can reproduce in 1.5 or trunk.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Keywords: testcase
Resolution: --- → WORKSFORME
Summary: no background color and broken border for absolute-positioned elements outside viewport → No background color and broken border for absolute-positioned elements outside viewport
You need to log in before you can comment on or make changes to this bug.