can't copy LISTS between address books

RESOLVED DUPLICATE of bug 42879

Status

Thunderbird
Address Book
RESOLVED DUPLICATE of bug 42879
13 years ago
13 years ago

People

(Reporter: philiptdotcom, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

can't copy LISTS between address books: I just imported LDIF file with many addresses including 2 lists, tried to drag-n-drop either of the 2 lists to the "Personal Address Book" from the new address book, but can't do it; cursor does NOT CHANGE from "arrow" to "arrow with rectangle" (as it does, e.g., when drag-n-dropping a CARD).

Reproducible: Didn't try

Steps to Reproduce:
1. import LDIF file including lists
2. drag-n-drop one of the newly-imported lists to "Personal Address Book"
3. (doesn't work)

Actual Results:  
doesn't work (cursor doesn't even change from normal arrow to "loaded-for-copy" arrow+rectangle)

Expected Results:  
list should be copied* (*actually it would make more sense for the list to be MOVED--or at least for the user to have the option to MOVE vs. COPY the list--but that's another story altoghether)

feel free to contact me (mozilla@philipt.com) if more details are needed
You should be able to copy lists between address books, I believe you are trying to drag and drop the list from the left-hand pane of the address book window. 

The current method is to select the address book then drag the list from the pane on the right (that shows cards and lists) to the new address book. However, if you do that you'll come across bug 42879. So the best way currently would be to create a new list & drag and drop the cards from one to the other.

I'm therefore going to dup this to bug 42879 as you can't copy or move lists - which is what that bug is also saying.

*** This bug has been marked as a duplicate of 42879 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

13 years ago
>You should be able to copy lists between address books

Agreed, but it doesn't work...

>I believe you are trying to drag and drop the list from the left-hand pane of the address book window.

Yes, which should be able to be done...

>The current method is to select the address book then drag the list from the
pane on the right (that shows cards and lists) to the new address book.
However, if you do that you'll come across bug 42879.

Correct (i.e., this doesn't work)...

>So the best way currently would be to create a new list & drag and drop the cards from one to the other.

Thanks for the temporary workaround... but obviously this is not a good long-term solution (esp., as noted by others, if users [like me] have lists with many members).

Thanks!
You need to log in before you can comment on or make changes to this bug.