Cant download/install themes (Walnut by Kayser;) I get the 'software install disabled' thingy

RESOLVED DUPLICATE of bug 310737

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 310737
13 years ago
13 years ago

People

(Reporter: gravdigr, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

When trying to "install theme now" I get the 'software installation currently disabled...click 'edit options' to enable it & try again' at the top of page.  I do this (content..'warn me when websites' etc..add site to 'allow' list (calls for typing EXACT web address, but EXACT address does not appear in list) and things do not change).  Also when closing Firefox, I get warning for canceling "x" number of downloads, "x" = number of times I tried to install theme (any theme  btw).  Check download manager, nothing shown.  To close manager, I have to 'x' the pane however many times I tried to install theme.  Checked the bug reports, but I may as well have been tryng to read Sanskrit, too technical for me.  Any help would be greatly appreciated.  Thanx.

Reproducible: Always

Steps to Reproduce:
1.Pick theme, any theme from 'addons.mozilla.org/themes'-->'Install now'
2.'software installation currently disabled...click 'edit options' to enable it & try again'
3.click 'edit options' add website to 'allow list'.  No Change.

Actual Results:  
Nothing.  Theme is not dowloaded/installed.

Expected Results:  
As in 'my' previous version of Firefox, the theme should have magically appeared upon restarting Firefox.

If I try five times (or any other number of times) to download theme, later when closing Firefox, I get a warned that I'm canceling that many downloads.  When I check the download manager, there are no pending downloads shown.  Upon closing the manager pane, it stays there until I click the little x in the upper left corner the same number of times.
Type about:config into the address bar, then find the entry titled xpinstall.enabled and set it to true.

*** This bug has been marked as a duplicate of 310737 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

13 years ago
(In reply to comment #1)
> Type about:config into the address bar, then find the entry titled
> xpinstall.enabled and set it to true.
> Many thanx 'rflint@dslr.net' for the xpinstall.enabled tip.  Worked like a charm, loaded Kayser's walnut theme right up.  Great theme btw.  Thanx again, Gravdigr
You need to log in before you can comment on or make changes to this bug.