1.5 Small Regression vs 1.0.7 / Bad filename associated to "save link target"

VERIFIED DUPLICATE of bug 299372

Status

()

VERIFIED DUPLICATE of bug 299372
13 years ago
13 years ago

People

(Reporter: aaa.vergnes, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8) Gecko/20051111 Firefox/1.5

When I try to "save link target" on the PDF icon, the name of the saved file should be "d37" like with Firefox 1.0.7 but it gives you "view" with 1.5.
For any PDF that would be linked like that it will give "view" forcing the user
to correct the filename for each download.

Because it seens impossible to attach a file:

text to create file:

<html><head><!--DOCTYPE HTML PUBLIC "-//L //EN"
        "http://www.xxx"-->

 
  <meta http-equiv="Exp" content="0"><title>intra engine</title>
  
  <link rel="stylesheet" type="text/css" title="style1" href="bug1p5only.php_fichiers/intra.css">
  <script language="Javascript" src="bug1p5only.php_fichiers/lib.js"></script><!-- // formulaires -->


<script language="JavaScript" type="text/javascript" src="bug1p5only.php_fichiers/language.js"></script>
<script language="JavaScript" type="text/javascript" src="bug1p5only.php_fichiers/formctrl.js"></script>
<script language="JavaScript" type="text/javascript" src="bug1p5only.php_fichiers/aformctrl.js"></script></head><body onunload="" onload="initform('form_blank_add',document.form_blank_add);initform('form_file_add',document.form_file_add);initform('form_note_add',document.form_note_add);initform('form_url_add',document.form_url_add);" bgcolor="#ffffff" link="MediumBlue" text="#000066" vlink="MediumBlue">
  <center>

		<table border="0" cellpadding="0" cellspacing="0" width="90%">
			<tbody><tr bgcolor="#ffffff">
				
				<td align="left"><a title="Contact" href="mailto:xxxx@xxxxxxx.com"><img src="bug1p5only.php_fichiers/blank.gif" border="0"></a></td>
				<td align="right" bgcolor="#ffffff"><img src="bug1p5only.php_fichiers/blank.gif" title="Add a blank" border="0">
<a href="http://xxxxxx/modify.php?vue=expand&amp;operation=search&amp;parent=1200" onclick="" title="Search a doc" target=""><img src="bug1p5only.php_fichiers/blank.gif" border="0"></a>
</td>
			</tr>
			
		</tbody></table>
	<table border="2" width="90%"><tbody><tr><td valign="top" width="35%"><table valign="top" cellpadding="0" cellspacing="0"><tbody><tr><td><a href="http://xxxxxx/browse.php?vue=tree&amp;parent=1" onclick="" title="" target=""><img src="bug1p5only.php_fichiers/blank.gif" border="0"> Documentation</a></td></tr>
<tr><td><img src="bug1p5only.php_fichiers/blank.gif" border="0"><img src="bug1p5only.php_fichiers/blank.gif" border="0"><img src="bug1p5only.php_fichiers/blank.gif" border="0"><a href="http://xxxxxx/gbrowse.php?vue=tree&amp;parent=133" onclick="" title="" target=""><img src="bug1p5only.php_fichiers/blank.gif" border="0"> </a></td></tr>
<tr><th colspan="10" align="left">PuV </th></tr><tr bgcolor="#ffffff">
<td colspan="4"><a href="http://xxxxxx/view.php?operation=viewfile&amp;id=774" onclick="" title="View file 37.pdf" target="blank"><img src="bug1p5only.php_fichiers/pdf.gif" border="0"> d37</a></td>
<td>9 Ko</td>
<td align="center">06 Janvier 2003</td>
				<td></td>
<td align="center"></td>
</tr>
<tr></tr><tr bgcolor="#ffffff">
<td align="center">Siep 21</td><td align="center">&nbsp;</td>
<td align="center"></td>
</tr>
				<tr><td></td>
<td align="center"></td>
</tr>
</tbody></table></td></tr></tbody></table>
  </center>
 </body></html>

Reproducible: Always

Steps to Reproduce:
1. unzip the attached testcase (very simple and small file)
2. load it into Firefox 1.5 and Firefox 1.0.7
2.Click right on PDF icon/ "save link target"
3.Observe the filename you get automatically, this is not the good filename for 1.5
4. Do the same with Firefox 1.0.7, the filename is really the filename pointed by the link
Actual Results:  
Firefox 1.5 gives "view" as filename or "view.php" 
Firefox 1.0.7 gives "d37" as filename (the correct one)

Expected Results:  
Get the same filename between both versions (1.0.7 correct) else
it becomes a nightmare to enter the correct filename for each download
and may be a loss if overwritten is possible.

about:buildconfig

Build platform
target
i586-pc-msvc

Build tools
Compiler 	Version 	Compiler flags
$(CYGWIN_WRAPPER) cl 	12.00.8804 	-TC -nologo -W3 -Gy -Fd$(PDBFILE)
$(CYGWIN_WRAPPER) cl 	12.00.8804 	-TP -nologo -W3 -Gy -Fd$(PDBFILE)

Configure arguments
--enable-application=browser --enable-update-channel=release --enable-optimize --disable-debug --disable-tests --enable-static --disable-shared --enable-official-branding --enable-svg --enable-canvas --enable-update-packaging
(Reporter)

Comment 1

13 years ago
Created attachment 205740 [details]
very small ZIP with an HTML/PHP page + directory with small icons/files
*** Bug 320146 has been marked as a duplicate of this bug. ***

Comment 3

13 years ago

*** This bug has been marked as a duplicate of 299372 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.