All users were logged out of Bugzilla on October 13th, 2018

It's impossible to delete or detach attachment via File Menu

VERIFIED FIXED in Thunderbird2.0

Status

--
major
VERIFIED FIXED
13 years ago
12 years ago

People

(Reporter: gorky, Assigned: mscott)

Tracking

({fixed1.8.1, verified1.8.0.2, verified1.8.1.3})

Thunderbird2.0
x86
All
fixed1.8.1, verified1.8.0.2, verified1.8.1.3

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [qa:verified-tb-1802])

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
Attachments can be deleted or detached from attachment context menu, but not from File -> Attachments -> (Attachment name) -> Detach.../Delete. JavaScript Console throws following errors:

Error: this.attachment.detachAttachment is not a function
Source File: chrome://messenger/content/messenger.xul
Line: 1

Error: this.attachment.deleteAttachment is not a function
Source File: chrome://messenger/content/messenger.xul
Line: 1

Tested on both new and old profile, on Windows and Linux.
I can confirm this on Linux with the 20051201 branch build.
(Assignee)

Comment 2

13 years ago
this is unfortunate.

we'll have to try to fix this for 2.0 and release note it for 1.5
Status: NEW → ASSIGNED
Target Milestone: --- → Thunderbird2.0
Created attachment 207008 [details] [diff] [review]
proposed fix (for trunk)

This fixes it for me, not sure if the original methods were supposed to work? (they do seem to exist in the mailnews version of msgHdrViewOverlay.js)
Attachment #207008 - Flags: review?(mscott)
(Assignee)

Updated

13 years ago
Attachment #207008 - Flags: review?(mscott) → review+
(Assignee)

Comment 4

13 years ago
fixed on the trunk. leaving open till I check this in for 2.0 on the 1.8 branch.
(Assignee)

Updated

13 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Keywords: fixed1.8.0.1, fixed1.8.1
Resolution: --- → FIXED
(Assignee)

Comment 5

13 years ago
1.8.0.2 is technically the first release with this Thunderbird fix. 
Keywords: fixed1.8.0.1 → fixed1.8.0.2

Comment 6

13 years ago
verified with Windows Thunderbird 1.5.0.2 20060308
Status: RESOLVED → VERIFIED
Keywords: fixed1.8.0.2 → verified1.8.0.2
Whiteboard: [qa:verified-tb-1802]
*** Bug 304359 has been marked as a duplicate of this bug. ***
verified fixed 1.8.1.3 using Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8.1.3) Gecko/20070326 Thunderbird/2.0.0.0 Mnenhy/0.7.5.0 ID:2007032620 - the steps to reproduce are working fine for me - also no error on error console
Keywords: verified1.8.1.3
You need to log in before you can comment on or make changes to this bug.