All users were logged out of Bugzilla on October 13th, 2018

Firefox browser initializes to a McDonald's site, regardless of what is in the preferences for start page.

RESOLVED INVALID

Status

()

--
major
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: merlinsweed, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

I am reporting this as a bug, since your product does not conform to the documentation.
When I put my choice for a start page in "Preferences", I expect that page to appear every time I start the browser. BUT NO. Somebody in development decided that harrassing customers with the McDonald's start page would be acceptable advertising.
As a result, neither you nor McDonald's has ANY SWAY with me whatsoever.

Reproducible: Always

Steps to Reproduce:
1. Start browser
2. Browser starts with a McDonald's page instead of the page in "Preferences".
3.

Actual Results:  
I get the McDonalds page.

Expected Results:  
Browser should have started with "WSJ Online" rather than the McDonald's page

If this is your idea of advertising, grow up.
(Reporter)

Updated

13 years ago
Alias: McDonalds
What command line is used to launch the browser? Something including "mc", maybe? Often cases like these are the result of some parameter being passed in as a URL, which is then passed through a Google "I'm feeling lucky" search, which often leads to unexpected results.
The URL for McDonalds is isn't in our codebase at all except for a newsgroup listing not compiled into Firefox. http://lxr.mozilla.org/mozilla1.8/search?string=mcdonalds

This is a configuration issue on your end, not a bug. See the MozillaZine forums for help in determining what's wrong with your setup. http://forums.mozillazine.org

I also highly recommend you read the following prior to filing another bug or submitting anything further to this one. https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
Alias: McDonalds
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.