Flash plugin crashes when accessing a site with Flash animation [@ ActionList::PushAction]

RESOLVED INVALID

Status

--
critical
RESOLVED INVALID
13 years ago
2 years ago

People

(Reporter: jorge_schramm, Assigned: mmelanso)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2009-03-08, crash signature, URL)

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050325 Firefox/1.0.2
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050325 Firefox/1.0.2

When accessing to the specified URL which contains flash animation, firefox crashes and closes all windows.

Reproducible: Always

Steps to Reproduce:
1. Start firefox
2. Create an account at www.portugalforum.de
3. access http://www.portugalforum.de/chat/flashchat.php


Actual Results:  
Starts flash animation and crashes within a few seconds



I will attach a backtrace
(Reporter)

Comment 1

13 years ago
Created attachment 205856 [details]
Backtrace

Comment 2

13 years ago
Hrm... I don't even know if this is our fault. 

Jorge, could you download 1.5 and see if this still occurs? 1.0.2 is super old.
Severity: major → critical
Component: General → Plug-ins
Keywords: crash
Product: Firefox → Core
Summary: Flash PlugIn generates a segmentation violation when accessing to a site with flash animation → Flash plugin crashes when accessing a site with Flash animation [@ ActionList::PushAction]
Version: unspecified → 1.7 Branch

Comment 3

13 years ago
#6  0xb2842a88 in ActionList::PushAction () from /home/aguthrie/.mozilla/plugins/libflashplayer.so
#7  0xb27f6c84 in BehaviorList::DoEvent () from /home/aguthrie/.mozilla/plugins/libflashplayer.so
#8  0xb286fc0d in ScriptPlayer::PushDataComplete () from /home/aguthrie/.mozilla/plugins/libflashplayer.so
#9  0xb286bd14 in ScriptPlayer::PushImageData () from /home/aguthrie/.mozilla/plugins/libflashplayer.so
#10 0xb289263a in CorePlayer::UrlStreamWriteNotify () from /home/aguthrie/.mozilla/plugins/libflashplayer.so
#11 0xb289260b in CorePlayer::UrlStreamWrite () from /home/aguthrie/.mozilla/plugins/libflashplayer.so#12 0xb28a4512 in URLStream::StreamWrite () from /home/aguthrie/.mozilla/plugins/libflashplayer.so
#13 0xb290eae9 in NPP_Write () from /home/aguthrie/.mozilla/plugins/libflashplayer.so
#14 0xb290c62c in Private_Write () from /home/aguthrie/.mozilla/plugins/libflashplayer.so
#15 0xb5d86372 in ns4xPluginStreamListener::OnDataAvailable (this=0x88f7460, pluginInfo=0x88ebf98, input=0x893f768, length=157) at /moz/mozilla/modules/plugin/base/src/ns4xPluginInstance.cpp:543
#16 0xb5d945dc in nsPluginStreamListenerPeer::OnDataAvailable (this=0x8943180, request=0x8995d28, aContext=0x0, aIStream=0x893f768, sourceOffset=1081, aLength=1127) at /moz/mozilla/modules/plugin/base/src/nsPluginHostImpl.cpp:2213
#17 0xb6ed3534 in nsStreamListenerTee::OnDataAvailable (this=0x8943100, request=0x8995d28, context=0x0, input=0x8a80f8c, offset=1081, count=1127) at /moz/mozilla/netwerk/base/src/nsStreamListenerTee.cpp:97
#18 0xb6f5fc06 in nsHttpChannel::OnDataAvailable (this=0x8995cf8, request=0x89423d0, ctxt=0x0, input=0x8a80f8c, offset=1081, count=1127) at /moz/mozilla/netwerk/protocol/http/src/nsHttpChannel.cpp:4185
#19 0xb6ea4f0d in nsInputStreamPump::OnStateTransfer (this=0x89423d0) at /moz/mozilla/netwerk/base/src/nsInputStreamPump.cpp:437
#20 0xb6ea5453 in nsInputStreamPump::OnInputStreamReady (this=0x89423d0, stream=0x8a80f8c) at /moz/mozilla/netwerk/base/src/nsInputStreamPump.cpp:340
#21 0xb7da1379 in nsInputStreamReadyEvent::EventHandler (plevent=0x8a4808c) at /moz/mozilla/xpcom/io/nsStreamUtils.cpp:120
#22 0xb7dceb9e in PL_HandleEvent (self=0x8a4808c) at /moz/mozilla/xpcom/threads/plevent.c:688
#23 0xb7dcea2a in PL_ProcessPendingEvents (self=0x80a2dd8) at /moz/mozilla/xpcom/threads/plevent.c:623#24 0xb7dd1aad in nsEventQueueImpl::ProcessPendingEvents (this=0x80a2d90) at /moz/mozilla/xpcom/threads/nsEventQueue.cpp:417
#25 0xb5cfc190 in event_processor_callback (source=0x83bcd00, condition=G_IO_IN, data=0x80a2d90) at /moz/mozilla/widget/src/gtk2/nsAppShell.cpp:67
#26 0xb772f31c in g_vasprintf () from /usr/lib/libglib-2.0.so.0
#27 0xb77084ee in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#28 0xb770b4f6 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#29 0xb770b7e3 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#30 0xb7b0ce65 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#31 0xb5cfcb86 in nsAppShell::Run (this=0x83047a8) at /moz/mozilla/widget/src/gtk2/nsAppShell.cpp:139
#32 0xb709777f in nsAppStartup::Run (this=0x8304760) at /moz/mozilla/toolkit/components/startup/src/nsAppStartup.cpp:161
#33 0xb7f250ed in XRE_main (argc=2, argv=0xbfc58764, aAppData=0x8049820) at /moz/mozilla/toolkit/xre/nsAppRunner.cpp:2289
#34 0x08048676 in main (argc=2, argv=0xbfc58764) at /moz/mozilla/browser/app/nsBrowserApp.cpp:61

Updated

13 years ago
Version: 1.7 Branch → Trunk

Updated

13 years ago
Assignee: nobody → msintov
(Reporter)

Comment 4

13 years ago
> Jorge, could you download 1.5 and see if this still occurs? 1.0.2 is super old.
I tried to emerge 1.5 from gentoo but the package does not compile on my system (obviously some files missing).

Updated to the newest available version provided by gentoo: mozilla-firefox 1.0.7-r4 and mozilla-flash 7.0.61.
But the problem persists (same backtrace).

BTW: sometimes I'm able to open the URL, but 90% of the times firefox (or the plugin) crashes.
(Reporter)

Comment 5

13 years ago
Created attachment 206002 [details]
Illegal-Operation-Popup on W2k (Firefox 1.0.7)

Maybe this might help: when I access the URL with my Firefox 1.0.7 on W2K, I get the attached popup.

Comment 6

13 years ago
Jorge, the stack I posted in comment 3 is from one of my own trunk builds. So you can disregard my comment 2 now.

Comment 7

13 years ago
I get this bug with Firefox 1.5 as well as with Mozilla 1.7.12 on a gentoo linux when starting the Flash based analysis software we sell. As far as I can tell, in my case it is loosely related to large amounts of XML data being parsed. I can confirm that the bug occurs right away after loading the page and only on 90% of the occasions.
My guess would be that this is a bug in the flash plugin. Here's what I get on stderr/stdout, if I start the browser from a terminal (note that the messages are almost identical for Firefox and Mozilla):

/usr/libexec/mozilla-launcher: line 119:  6195 Speicherzugriffsfehler  "$mozbin" "$@"
firefox-bin exited with non-zero status (139)

/usr/libexec/mozilla-launcher: line 119:  6238 Speicherzugriffsfehler  "$mozbin" "$@"
mozilla-bin exited with non-zero status (139)

Hope this helps. It is a very annoying bug for me, as I have to use our application every day and I sometimes need to restart the browser and login again about ten times in a row.

Comment 8

13 years ago
I want to confirm I see such a bug too. I see it when going to http://www.hell.co.nz/ and clicking on Christchurch (within the flash app).

And although it is flash-related, I think the bug is within Firefox (I've got 1.5.0.1 under FedoraCore4), because I also have Opera installed, and it uses the SAME FLASH .SO AS FIREFOX (libflashplayer.so) - and yet has no problem with that site.

QA Contact: general → plugins

Updated

13 years ago
Assignee: msintov → nobody

Updated

13 years ago
Assignee: nobody → mmelanso

Comment 9

11 years ago
I want to confirm that I am seeing this bug, too, in both Firefox (2.0.0.4) and Seamonkey (1.1.2) on Linux. I don't recall seeing this bug until fairly recently, and I'm not sure what version caused the problem. One interesting thing about this bug is that I can download and install the latest version of the Flash Player, and if I do so and then go to the Adobe site that is intended to test the Flash Player, it appears to work correctly. That is, it works, and there is no crash. HOWEVER, if I visit certain other sites, in particular cnn.com and java.com, then I get an immediate crash. It almost makes me wonder whether there is some conflict between the Flash Player and Java, although this is pure speculation.

Comment 10

10 years ago
Do you still see this problem using latest version of Firefox and Flash (10)?

If you do, please comment.
If you do not see the problem, please close the bug - don't use resolution=FIXED, change resolution to:
- INVALID if you believe the problem was flash player
- WORKSFORME if you believe the problem was in Firefox
- INCOMPLETE if it is impossible to test (url or testcase is gone)
Whiteboard: closeme 2009-03-08
The stack in comment 3 looks like it was a Flash plug-in bug.
Please file a new bug report if the problem reoccurs in Firefox 3 with
Flash 10 (or newer).  Thanks.

-> INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID

Updated

9 years ago
Component: Plug-ins → Flash (Adobe)
Product: Core → Plugins
QA Contact: plugins → adobe-flash
Version: Trunk → 7.x
Crash Signature: [@ ActionList::PushAction]

Comment 12

2 years ago
Version and milestone values are being reset to defaults as part of product refactoring.
Version: 7.x → unspecified
You need to log in before you can comment on or make changes to this bug.