Short cut key(Alt c/Alt v) for Copy/paste doesn't work on ABook with linux build

VERIFIED WORKSFORME

Status

SeaMonkey
MailNews: Address Book & Contacts
P3
normal
VERIFIED WORKSFORME
18 years ago
13 years ago

People

(Reporter: ji, Assigned: chuang)

Tracking

({access})

Trunk
Future
access

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3-])

(Reporter)

Description

18 years ago
Build: 2000-03-15-12-M15-nb1b linux build

On ABook's new card or edit window, short cut keys for copy/paste (Alt c & Alt v) are not working.
We don't have menu items for copy/paste on those windows.

Steps of reproduce:
 
1. Bring up Address Book
2. Open New Card window
3. Enter something in the First: field.
4. Highlight the firstname and press Alt c
5. Click on Nickname: field and press Alt v

Nothing is copied to the Nickname field.

Windows build doesn't have this problem

Comment 1

18 years ago
I could copy/paste On ABook's new card or edit windows with the steps provided 
on linux 2000031606 and MAC 2000031505 beta builds.
(Reporter)

Comment 2

18 years ago
It looks like we have two groups of short cut keys for copy/paste on linux:
Ctrl c & Ctrl v, Alt c & Alt v.
On html and mail composer window, both are working, but on the
address book's new card and edit window, only Ctrl c & Ctrl v are working,
Alt c & Alt v are not working.
(Reporter)

Comment 3

18 years ago
Changed the summary accordingly.
Summary: Copy/paste doesn't work on ABook with linux build → Short cut key(Alt c/Alt v) for Copy/paste doesn't work on ABook with linux build

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: M16

Updated

18 years ago
Keywords: ui
QA Contact: lchiang → nbaca

Updated

18 years ago
Target Milestone: M16 → M17

Comment 4

18 years ago
Not M16 stopper.  Moving to M17.  Please add keyword beta2 if this is a beta2 
blocker.

Comment 5

18 years ago
Mass move mailnews bugs to Putterman.  Ouch.
Assignee: hangas → putterman
Status: ASSIGNED → NEW

Comment 6

18 years ago
*** Bug 42878 has been marked as a duplicate of this bug. ***

Comment 7

18 years ago
it does happen now on Windows so changing Platform to 'ALL' and marking #42878 a 
dup of this bug.
OS: Linux → All
Hardware: Other → All

Updated

18 years ago
Keywords: nsbeta3
Target Milestone: M17 → M18

Comment 8

18 years ago
nominating for beta3 and moving to M18.

Comment 9

18 years ago
mail triage team marking nsbeta3-
Whiteboard: [nsbeta3-]
Target Milestone: M18 → Future

Comment 10

18 years ago
Mark me confused but I don't think 42878 is a dupe, because I can copy using 
crtl-c and paste w/ ctrl-v win32 2000080408.

Are you saying that linux is supposed to support both ctrl-c and alt-c? I 
thought that only one of the two should work.

Comment 11

17 years ago
reassigning to chuang.
Assignee: putterman → chuang

Comment 12

17 years ago
Build 2001-01-17-08: NT4, Linux 6.2, Mac 9.04
Marking as Worksforme. 
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Keywords: access
Resolution: --- → WORKSFORME

Comment 13

17 years ago
Verified Fixed.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.