Warn people when they mark a bug as blocking or depending on a closed bug

RESOLVED WONTFIX

Status

()

Bugzilla
Creating/Changing Bugs
P4
enhancement
RESOLVED WONTFIX
12 years ago
2 years ago

People

(Reporter: Douglas Calvert, Unassigned)

Tracking

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Bugzilla should complain if a user enters a new bug that blocks a bug that is resolved. Righ now it should either:
a: complain
b: reopen the other ticket

Reproducible: Always

Steps to Reproduce:
1. open ticket#1
2. resolve ticket#1
3. open ticket#2 and have it block ticket#1

Actual Results:  
ticket#2 is accepted without any issue

Expected Results:  
Bugzilla automagically reopens ticket#1
or
Worst case scenario it complains and tells the user that there is a dependency problem.
(Reporter)

Comment 1

12 years ago
Best case fix:
A new param that says
new tickets that block resolved bugs should
a. complain
b. reopen resolved ticket
c. do nothing

Updated

12 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

8 years ago
Due to the way people use dependencies to track regressions, meta bugs, etc..., enforcing this behavior is not desired. Even different projects (products) within the same Bugzilla installation (e.g. bmo) have different ways to track such bugs, so this feature couldn't be used consistently.
Severity: minor → enhancement
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
(In reply to comment #2)
> Due to the way people use dependencies to track regressions, meta bugs, etc...,
> enforcing this behavior is not desired. Even different projects (products)
> within the same Bugzilla installation (e.g. bmo) have different ways to track
> such bugs, so this feature couldn't be used consistently.

Can you tell as about that "way"? I mean, just a simple use case.
Even if you come up with a good example, I think this bug is worth reopening and rephrasing it to at least emit a warning in this case. I would bet that 99% of the cases when people do this, they didn't intend to do it.

Comment 4

8 years ago
  I think a warning is reasonable, but we would have to fix the message system first so that it can take multiple messages.
Status: RESOLVED → REOPENED
Priority: -- → P4
Resolution: WONTFIX → ---
Summary: New ticket should not block closed bugs → Warn people when they mark a bug as blocking or depending on a closed bug

Comment 5

2 years ago
(In reply to Max Kanat-Alexander from comment #4)
>   I think a warning is reasonable, but we would have to fix the message
> system first so that it can take multiple messages.

I disagree about displaying a warning. It would do it all the time on e.g. bmo. This is really installation-specific and probably an undesired warning.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.