End dates for events read from remote .ics files are set to 1969 and don't display a correctly sized color block

RESOLVED DUPLICATE of bug 315719

Status

Calendar
Internal Components
RESOLVED DUPLICATE of bug 315719
12 years ago
11 years ago

People

(Reporter: Matt Bower, Assigned: John Gray)

Tracking

Sunbird 0.3a1
x86
Windows XP

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/416.12 (KHTML, like Gecko) Safari/416.13
Build Identifier: Sunbird 0.3 alpah1

Sunbird program is reading about 7 remote .ics files which are maintained by Apple computers running iCal on OS 10.3 & 10.4. Many of the events on these remote calendars are being read by Sunbird with an end date in 1969 (checked by double-clicking on the event to bring up the event editing dialog box) which is making the color blocks on the calendar view display incorrectly and is maybe the cause of why Sunbird takes a really long to load since it has to calculate the really large sizes of all the event color blocks. Problem is very noticable in Week view in that events that are only supposed to be an hour long take display as taking the entire day on multiple days.

Reproducible: Always

Steps to Reproduce:
1. Subscribe to at least one (maybe more) remote calendars maintained by iCal on a WebDAV server.
2. Go to Week view
3.

Actual Results:  
Event color blocks took up more space than they were supposed to and end dates were set to 1969

Expected Results:  
Event end dates should be what they were set to on the remote .ics files and event color blocks for an event that is set for an hour should only take up an hour's worth of space on the calendar (especially week view)

When Sunbird starts up, it gets error windows for each remote calendar it's trying to read. The errors are just errors reading the calendar: 'calendar_name' and sometimes set the calendar to read-only mode.
(Reporter)

Updated

12 years ago
Version: unspecified → Sunbird 0.3a1

Comment 1

12 years ago
(In reply to comment #0)
> Event color blocks took up more space than they were supposed to and end dates
> were set to 1969

This sounds like the problem described in bug 315719. Can you check the events in your *.ics-files please?

Comment 2

12 years ago
Matt,

please retest with the latest sunbird build found here:
 http://ftp.mozilla.org/pub/mozilla.org/calendar/sunbird/nightly/latest-trunk/
and check if the problem still exist.

Comment 3

12 years ago
(In reply to comment #2)
> Matt,
> 
> please retest with the latest sunbird build found here:
>  http://ftp.mozilla.org/pub/mozilla.org/calendar/sunbird/nightly/latest-trunk/
> and check if the problem still exist.
> 

I've retested with the latest build (dated 03-Jan-2006 on Linux) and found that it works now (the end dates are fine).
However an allday event appears on the multiweek and month views, but not on the day or week view.

Also I checked "Store Dates in UTC" in the Tools/Options/General and selected my timezone (Europe/Sofia) in Tools/Options/My Timezone. This caused the F1 races from http://ical.mac.com/ical/F1.ics to appear in correct local times (about 15:00) but they're displayed as bars starting at 12:00 in the Day view.

Comment 4

12 years ago
Resolving as a duplicate based on the reporter's confirmation that this was now fixed.  The issue about all-day events not showing the day.week views is already filed as another bug.

*** This bug has been marked as a duplicate of 315719 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Component: libical → Internal Components
The bugspam monkeys have been set free and are feeding on Calendar :: Internal Components. Be afraid for your sanity!
QA Contact: libical → base
You need to log in before you can comment on or make changes to this bug.