intermittent crash consuming 100% of CPU time

VERIFIED INVALID

Status

P3
critical
VERIFIED INVALID
19 years ago
14 years ago

People

(Reporter: arkady, Assigned: cbegle)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
We have www application written in Javascript and Java with extensive use of
LiveConnect. The Javascript code uses many dynamic html features.

Once in a while Netscape browser gets really confused running this mixture. On 
the
surface it looks like the browser is consuming 100% CPU time on the machine,
roughly equally divided between user space and kernel space. The problem occurs
on both FreeBSD browser and WinNT.

The following investigation was done on FreeBSD, Netscape version 4.61 and
4.7. truss shows that browser does select() syscall which immediately returns,
then browser does non-blocking read on X11 socket which in turn immediately
returns 0 bytes, and then the cycle continues. There are some gettimeofday() and
signal() calls in between.

Disabling KeepAlive setting in apache server servicing the site seems to provoke
the problem more often. Use of URLConnection() class from Java applet seems to
provoke it even more. Unfortunately none of these is not a sole reason because 
the
problem happens without them, only less frequently. 

Attempts to run simplified version of the application with certain pieces of
functionality disabled yielded inconclusive results, we could not figure out 
what
was the feature triggering it out. It almost feels like just amount of code was
too much and simply reducing line count removes the problem (and I do understand
it could not be right).
arkady, from reading your description, it sounds like this a problem you are 
having with Netscape 4.x, not with Mozilla/next-generation Netscape. Is that 
correct? 

If so, (1) sorry, I didn't realize that when talking on the phone, (2) we have 
to mark this bug INVALID because bugzilla is only for Mozilla/next-generation 
Netscape bugs, not 4.x bugs, and (3) please see 
http://developer.netscape.com/support/ to learn about your options for getting 
developer support from Netscape.

Marking INVALID. arkady, if this is actually a bug you see on 
Mozilla/next-generation Netscape, please REOPEN the bug and tell us what build 
ID and milestone you saw it with. Thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → INVALID

Comment 2

19 years ago
verified invalid
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.