Cannot start Firefox anymore since last crash

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: Yves Goergen, Unassigned)

Tracking

1.5.0.x Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Opera/8.50 (Windows NT 5.1; U; de)
Build Identifier: Firefox 1.5 de

I visited a website that seemed to want to run a script. So I enabled NoScript to let it execute JavaScript. While reloading the page, Firefox crashed. I submitted the report, but Firefox wouldn't start anymore since then. Here's the message it prints in a message box:
---
Firefox beenden

Firefox wird bereits ausgeführt, reagiert aber nicht. Um ein neues Fenster öffnen zu können, müssen Sie zuerst den bestehenden Prozess Firefox beenden oder Ihren Computer neu starten.
---
There is no such Firefox process running and I did restart my computer. I just won't work. Reinstalling doesn't help and I really don't want to create yet another profile. Why do Firefox profiles go corrupt so often??

Reproducible: Always

Steps to Reproduce:
No idea, sorry
Actual Results:  
Error message above


Let me know what I can do or look up in my installation to help make it working again. I'm using Opera for now...

Comment 1

13 years ago
reporter: look in the windows task manager if the firefox.exe process is still active. If so, kill it and try starting firefox again.
(Reporter)

Comment 2

13 years ago
Ehm... from my original comment:
> There is no such Firefox process running and I did restart my computer.

To be clear, I meant I opened the task manager, looked for any firefox task (namely firefox.exe or similar-looking), there was none. Then I rebooted the computer. After each step, Firefox wouldn't start but only show this message box and after confirming it, it was gone. No browser window. I can try as often as I want, always the same result.

Btw, running Firefox in safe-mode shows the same error. What is that safe mode at all?
*** Bug 320447 has been marked as a duplicate of this bug. ***
Go to the Firefox profile directory and delete the file "parent.lock".
Than start FF

Comment 5

13 years ago
This is invalid. When you crashed, parent.lock wasn't removed which prevented you from using the same profile again. See http://kb.mozillazine.org/Profile_in_use for more info.
Severity: critical → normal
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
Version: unspecified → 1.5 Branch
(Reporter)

Comment 6

13 years ago
Hey hey, not that fast please. That file doesn't exist in the profile directory. I was looking for something like that but it isn't there. And yes, I looked in the right directory, I've been running 1.0 and 1.5 with separate profiles for some time, now there's only the 1.5 profile left since I found that Firefox 1.5 works good enough.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 7

13 years ago
I wouldn't be surprised if you're experiencing bug 319004.
(Reporter)

Comment 8

13 years ago
Okay, it wasn't a lock file, but just out of curiosity I checked if it finds the profile directory. Somehow the profiles.ini was reverted to a probably one week old version, I have no idea why. Anyway, I corrected it to the actual profile path, then started Firefox. It created a completely new profile (what for did I just correct the profile path?). Then I exited Firefox and corrected it once again, now I have my profile back up and running.

Thank you for the link, now do whatever is appropriate with this task. I do now think that the error message Firefox presented me is entirely wrong and should be replaced. There was no other Firefox instance, like it said, and there was no web link explaining what these words can actually mean. Instead it just couldn't find a directory on the disk.

Updated

13 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.