crash when moving a folder to a different folder

RESOLVED FIXED

Status

()

Firefox
Bookmarks & History
RESOLVED FIXED
12 years ago
8 years ago

People

(Reporter: Brian Ryner (not reading), Assigned: Brian Ryner (not reading))

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

12 years ago
We have some wacky AdjustIndices ordering that causes us to notify for an item that doesn't exist.  Fix coming up.
(Assignee)

Comment 1

12 years ago
Created attachment 206016 [details] [diff] [review]
fix

The key fix here is that we always want to delete the item from its old position before we adjust indices.  That way, we don't find the item we're deleting and think that it's been moved.  It's an extra database operation, but this isn't really a critical path.
Attachment #206016 - Flags: review?(brettw)
(Assignee)

Comment 2

12 years ago
checked in
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Updated

12 years ago
Attachment #206016 - Flags: review?(brettw) → review+
*** Bug 320327 has been marked as a duplicate of this bug. ***
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.