Closed Bug 320451 Opened 17 years ago Closed 13 years ago

Use style > Basic Style after reloading does not show :first-letter

Categories

(Core :: Layout, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 303076

People

(Reporter: bartolome.sintes, Unassigned)

References

()

Details

(Keywords: testcase)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; es-ES; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; es-ES; rv:1.8) Gecko/20051111 Firefox/1.5

If I select "Use style > None" and then I select "Use style > Basic", the page is shown as expected, but if I select "Use style > None", I reload the page (F5) and then I select "Use style > Basic", the p:first-letter style is not shown.

Reproducible: Always

Steps to Reproduce:
1. Open the page http://www.cdlibre.org/prueba/mozilla_bugs/051215_use_style/051215_use_style.html
2. Notice the p:first-letter style (size, padding and border, for instance)
3. Select "Use style > None"
4. Reload the page (press F5, for instance)
5. Select "Use style > Basic"
Actual Results:  
The p:first-letter style is not shown (if you then reload the page again, the style is shown).
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051215 Firefox/1.6a1

Confirmed with latest build. I have modified tescase to make its valid but same problem. 
I have corrected the testcase. Now it is valid XHTML 1.1. The problem is still present.
Attached file testcase
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20051215 Firefox/1.6a1 ID:2005121523

confirmed
Status: UNCONFIRMED → NEW
Component: General → Layout
Ever confirmed: true
Product: Firefox → Core
Version: unspecified → 1.0 Branch
Keywords: testcase
OS: Windows XP → All
QA Contact: general → layout
Hardware: PC → All
Version: 1.0 Branch → Trunk
I think this is basically a duplicate of bug 8253.
Depends on: 8253
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 303076
You need to log in before you can comment on or make changes to this bug.