Counter values are not stored, if increment done in :before.

RESOLVED DUPLICATE of bug 288946

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 288946
12 years ago
12 years ago

People

(Reporter: Santtu Lakkala, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Firefox/1.0.7 (Debian package 1.0.7-1)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

If calling counter-increment in :before (or :after), the counter is incremented, but the value is lost afterwards. However, if the counter variable is once used without :before or :after, it works.

This is easy to circumvent, but as this is the way it is used in w3c example code:
http://www.w3.org/TR/REC-CSS2/generate.html#counters
it should be fixed.

Reproducible: Always

Steps to Reproduce:
1. Go to the URL
2. You're done

Actual Results:  
The page says:
1. foo
1. bar
foo1.
1. foo
bar
2. bar
3. bar

Expected Results:  
The page should say:
1. foo
2. bar
foo3.
4. foo
bar
6. bar
7. bar

Comment 1

12 years ago
See Bug 288946, is that covering the same thing or is this bug something not covered there?
(Reporter)

Comment 2

12 years ago
Yes, sorry, it is basically the same issue.

Should've searched the "resolved" bugs too.

*** This bug has been marked as a duplicate of 288946 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.